Mystic vision doesn't work (screen freezes, no reward)

My mystic vision is not giving any reward. It shows the add and when it finish, the “ No add available check later” message appears. Happened last 5 times and the add is always about an airplane game.

Is someone experimenting same issue?

1 Like

Take a look at this thread, seems it’s happening to other people as well. Is it the same problem? Or slightly different?

1 Like

Yeah i’ve been getting this issue. At least one ad a day for the past few days where the ad has played all the way through then exactly the same problem as you. Not having the issue where the whole game is crashing like in the other thread. Although its not always the airplane game for me. Happened on the pirate ship game as well

Since version 39 dropped I’ve had this exact issue, and ads that freeze up occasionally and take at least 2 minutes to play, I don’t think I’ve had a day where I made it thru the whole day without something going wrong with it since then

I have the same issue that I watch the ad then there is no reward given. This has been happening for at least the last week. There are also times that the screen just locks up when the ad is finished. I have had to close out of the E&P app and start it again. And again there is no reward.

I had this issue 2 weeks ago. It stopped. Now back to it again. I used to be able to close out the game and come back in and do it again and then get reward. Now back to no reward. 12 hours now.

Sometimes (it is not the first time) when I choose an Ad to view, at the end there is not reward waiting for me. I think developers may be solve this because we are watching constantly the ads although the rewards are poor. Please, solve this.
The message that appears is “No ads available now”

Mystic Vision issues sadly have been reported many times…

FWIW forum users are players of E&P, just like you. Still doesn’t work? You can contact SG direct… Follow the link


I have anither problem with mystic vision. Ir Spears but don’t load. It’s freeze.

Are you able to see the little ! in the upper right corner? If so, hit it and a menu will ask you what you’d like to do. I always hit “hide” and then answer “repetative” for the next question. After that I need to close and restart my game.

Hopefully the next ad will work, but be prepared to repeat those steps if necessary. So far the most times I’ve needed to close and restart my game in a row is 9 times.

The same thing is happening on both my tablets, and my husband’s too. He always answers that the ad is “offensive” because he says he’s offended when it happens. There isn’t an option to say that the ad is broken and freezes.

What a pain🤐

I’m just getting a grey screen then says no ads available. Restart the game same issue.

same here. I have to close and restart the game to fix it.

I also have this issue. Every single day. Sometimes more than once. I find that if you exit the game, sometimes it allows you to watch the video again. But still no reward. It’s frustrating. Wasting data on videos for no reward at all

Same here. Vision is grey and you can only close it, nothing else. Anyone found a solution?

Its the same with me. 50% of chance to get reward. Restarting game is the solution sometimes.

Keep getting that no ad available been like this for about 24h please advise @Staff_SGG

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings