Mystic Vision Constantly on the fritz

Seems, once a week my Mystic Vision becomes available, despite it being time for use. That needs to get fixed, and more Mystic Visions would be nice, instead of one!!! Especially since lately the DEVELOPERS have been making acension items sparse.

1 Like

It’s not working for me either. I click it and nothing happens.

Same for me not working

I’ve the same issue :frowning:

Same problem since 24 hours. No mystic Vision
I

last couple of days its being a problem for me too.

I have the same issue for two days.

We are aware of the issue that prevents some players from seeing ads on the Mystic Tower. Please note that there might be limited availability of the ads based on your location. In some cases the issue is temporary, so if you’ve just encountered it, please try again a bit later.

1 Like

First of all I don’t seem to be able to post a new topic. But this is related to Mystic Vision. When clicked, it showed a black screen and hung the game. Have to restart again.

What platform do you use?

I experienced this yesterday, on android. I cleared my cache and also went to Settings, Google Settings, Ads and selected “Opt out of ad personalisation”. I then turned my phone off for 10sec then turned it on again.

This was my “fix” and hope it maybe of some help.

1 Like

I am using Android. Tried the above suggestion but still the same results.

Thanks Anyway!

In that case I’d suggest sending a support ticket.

1 Like

Do you have the same issue Pigi has posted?
If so, there is just no advertising available for your location, in this case it might help to take a look to the mystic visions outsite the primetimes ( in the morning, after work, in the evening)

If you have a red cross on the play button, its usually a cache or configuration issue of your cell, I need to clear the cache of the app in 2 of 3 times when the timer reached zero.

2 Likes

Ad’s dont load. Got to click on it many times before it works. Getting worse. Used to take 4/5 clicks.At present my record is 9 clicks to get it to work once. Irritating.

Thank I think they have resolved that.

1 Like

Hi, No red cross and it is clickable, it is a bug and it has been resolved.

So pleased to hear it’s been resolved! Here’s hoping you get some great loot :slight_smile:

1 Like

Thank you very much my dear!

1 Like

I’ve been having problems with the Mystic Vision as well. It usually takes 4 -5 tries before it works. I’ve tried soon after opening the game, after a couple of minutes, after an hour, etc. No real rhyme or reason to it as I can see. Don’t know if it my tablet, wifi, the game???

Cookie Settings