My E&P day will probably end in a dramatic way

I have been playing E&P for more than 2.5 years and it may now come to an abrupt and dramatic end.

So this morning, when I was working out in the gym, I clicked open E&P and decided to watch a MV, the game center screen popped out and asked me to accept their new T&C, after I did that, tutorial screen popped out and yes, I lost all my progress in the past 2.5 years…

I panicked. Restarted my device, reinstalled the app, none works. In fact, now they decided to assign me a new account as well :joy: I have already submitted a ticket to help center so hopefully I will be able to get my old account and progress back soon. Or otherwise it will certainly mark the end of my E&P days. I just don’t see myself restarting everything from zero again, knowing how much hard work you need to put in in order to be able to compete at a reasonable level.

Will keep you guys updated whether this thing can get solved.

PS: Petri, I don’t typically whine for help, but if I could get some extra attention from the SG support team, there would be great @Petri

7 Likes

Wow, sorry to hear this @KeeSnow , hope it will get solved very soon!

2 Likes

Yikes!!! That’s horrible. Hope it gets sorted out soon.

2 Likes

Calm down man, I had the exact same experience. You probably signed in using a different email to game center than the one you used to play E & P.

  1. Go to game center and log out

  2. Log in using the correct email. Try to log in to the game and if it’s another tutorial (new account), kill the app and repeat step 1.

Keep trying all the emails you could’ve used and you’ll get back your account soon enough.

Also, screw customer support. They’re not there to help anyone. They’re there to frustrate everyone long enough they’d give up.

6 Likes

Sorry to hear this @KeeSnow , hope you get your account recovered soon.

1 Like

Have you tried finishing the tutorial?

When I logged in on a new device, game always asked me to redo the tutorial and it appeared as if I started from the scratch. Only after finishing the tutorial my old account was back.

3 Likes

Thanks all for the kind words.

Just an update - I used the method suggested by @Ham.Cheese and I got my progress back! So looks like I messed up with the ID log in indeed.

The account ID has changed though. Am not sure what is the glitch here, but super excited that I got my account back.

My alliance mates already asking where I have been… :joy:

13 Likes

Woo hoo! Back in business! :tada::tada::tada::tada:

2 Likes

Yah, that happens… I have changed devices multiple times plus deleted and re-installed game many times in last 4 yrs… Only logging with that specific ID saves the game…

2 Likes

Awesome - glad it got sorted out @KeeSnow and kudos to @Ham.Cheese for sharing the fix!

3 Likes

Nice you got it solved :four_leaf_clover: I completely understand the panic!

Thats why I keep an older device with Wlan access only as a backup.

Happy gaming