My device isn't compatible with version

Hello.
I have Samsung Galaxy Mega and the phone is much better than the one I used to play this game before. The app says it is not compatible. Please advise.

That device should be supported.

Did you try out these troubleshooting tips: