[Master] Mystic Vision bugs, again

Thanks for the suggestion @marki , if it keeps up I may just do that.
:+1:

i did with exact same temu and 2 mores that i couldn’t see them again, 3 in total, works fine all

but know my alliance teammate that did too much and in his country not so many ads different so he struggles with mv know

1 Like

Is Mystic vision failing again? I’ve seen various adds lately without reward

Again? When was the last time it actually was working properly? It’s been years for me. Every time I send in a report to SG they tell me that it’s my connection… which is garbage. It happens to me no matter what internet connection I have or even what device.

1 Like

Well same for me, but it worked properly for about four months. They always say: update the game or connection problems :person_facepalming:

1 Like

6 times in a row I get the black screen with the grey bar at the top & it’s frozen. Forced to close the game & restart. 7th time it finally activated properly. Never known this issue b4. On my side anyway.

Yea, MV ads have been :poop: lately. The ad will crash with 1 or 2 seconds remaining, and then you have to force close it and the game and try again…all while SG is raking in ad revenue for every single ad we open up. So, instead of 2 you have to go through 4 ads and that doubles their ad revenue. Every day they keep convincing me it was a great idea to curtail and now stop spending on this garbage.

Ad for Pandora won’t let you close it after ad is done. The only option is instant install. I have had to uninstall Pandora at least 5 times now. And then restart game and hope the ad doesn’t come up again.

Stuck on “loading ads”. Tried restarting game.

same here stuck on “loading ads”

Mystic vision stuck on loading adds again.

1 Like

Same here, been stuck for about 2 hours

The same problem in Thailand

In the last 3 mystic visions, I’ve watched them, successfully closed them, but did not receieve any rewards. It simply closes the ad and returns to the game.

Twisted Triangle playable ad not working. Drops you to the game without reward.

1 Like

Same issue here on Android after build 2088. The in game support page also doesn’t come up.

Can we please go back to the stable build? Who drops untested builds into production and forces them upon users? Pretty amateur stuff from a company like SGG/Zynga/TT.

Basically almost every time I go to watch my first of the 3 MV it take a long time for the pop up bubble to appear an when I go to watch it nothing loads and I have to wait for it to give another pop up bubble and that one usually works. So it’s not totally unfunctional but it ends up taking a long time, I often spend more time waiting for the pop up bubble than watching the as.

I’m getting another bug now where it just opens a black screen with no ad and it plays for a while then goes back to the game and I don’t get a reward.

Two separate Mystic Visions that gave no reward in 24 hours.

I submitted a report and was told that my device, etc…are likely the problem.

Infuriating customer service.

:warning: Mod edit: Support answer is removed.

Currently getting no ads. Just the “loading ads” part. Started about 24hrs ago. Anyone got any answers, tried the usual restarting phone etc.