[Master] Mystic Vision bugs, again

Both of my devices (working iPad and not working iPhone) are at the latest version, both the OS and the game app. So that also is not really the issue or solution. But it still seems that not everyone is affected by this, what ever the actual reason is.

This worked for me as well!

Torafu, version 16.3.1 works, version 15.7.3 didn’t. All appear to be working now though.

Just went into the game and finally had an ad again. FYI, they were working perfectly, ready every 2 hours on the dot, until the update and then never loaded at all until today.

Oh. That worked! :+1: …and so obvious! Damn! :rofl: :see_no_evil: The Update on my iPhone was hidden.

I was already at the latest versions, like I said. So the update may help, but is not guaranteed to help. But yesterday evening ads started to “work” again for me, with no OS or App update :man_shrugging:

(“Work” as in the play button never actually showing the add before I force kill the game and start it again. The normal situation, that is.)

Looks like my MV is also back starting from this morning - I did update to the latest iOS version.

For me it is still not working,i’ve upgraded the ios on the phone,tried to turn on/off personalised ads in settings,turn on/off location tracking without any success…i was able to watch only 3 ads since i upgraded to 55.0.1 (2-3 days ago)

1 Like

this is true for me also. I updated my IOS, it started working again but not yesterday and today. I was able to watch 3-4 ads but nothing since.

I still have this problem btw. Updating my Iphone didn’t resolve this issue. I sometimes get to watch one Mystic Vision per day but that’s it. It says Loading Ads most of the time.

I’m from iPad and it’s been more than a week now that I have no ads for the entire day apart from a couple in the morning. I’m F2P and this is really damaging me, like it’s damaging all other players with this issue. please, take care of it already, I uploaded my software to the latest version and still nothing.

The bug is coming back… my MV is down again since last bright. Gosh this is so freaking annoying. @Petri please ask dev team to look into this… this is affecting many players in the community.

1 Like

Got problems with MV last 2 days, as well. This thing is annoying as f…

MV still doesn’t work normally, giving 1-3 visions per day. Is it ok or what?

Not sure this really needs a topic, but maybe if others are having an issue, SG will address it.

My mystic vision has not worked in probably close to 2 days now and it’s been temperamental over the last month or so, but really recently, especially last 2 day has not worked at all.

Whenever I get the draft kings ad in mystic vision, it will get 95% done with the add, according to blue bar at thr bottom, then reload back to 75% marker and go to 95% then reload to 75% amd over and over and over. You have to cancel out the app in order to get out of that loop. I’ve recorded it happening. It happens 3/4ths of the time. Can SG fix this, super annoying. Bc you close the app, mystic vision doesn’t always give you the reward for watching. I am on android. Anyone else see this issue?

Is anyone else experiencing problems with mystic vision. The ad will play and nothing happens. The icon reappears as if to watch another ad but it says no ads available at this time. This has been happening for several days. Anyone else experiencing this?

Hello welcome to the forum … MV has been a pain for some users in the past present and guess the future …
Going to move your topic there could be a solution to help you with the problem you are having :slight_smile:

1 Like

My mystic vision has not been functioning correctly for weeks and I have updated all the new updates. Can someone please look at it. It goes through the ad and nothing happens.

Hello! Is this happening to you? After pulling 2 free daily summons I’m trying to pull free summon, you know the one with the commercial. I’m on a 4th commercial now and no reward given. What gives SG?