[MASTER] E&P Store Discussion and Help

I’ll try that. Thank you :relaxed:

I will try that. Thank you :slightly_smiling_face:

I was able to get the first free gift with the new website launch, but I’m now unable to get he new one (Dunes Coins) on my iPad, I click the link, and I get an image of a QR code,

I haven’t tried on my iPhone yet (just updated to latest iOS last night),

The same “tricks” should work for claiming these new gifts too.

What tricks? I had ZERO issues getting the first gift.

hi, I have the same problem, it always says ‘connect the store to the game’ even if I go to the store from the game
it’s quite boring…


The game always opened back Firefox for me regardless what I have set for Default Browser on Andriod.
And claiming reward is only worked for me on Chrome.

So I needed to copy the link of the URL (while the page is still loading) from Firefox, and paste it to Chrome in order to be succesully login, and be able to claim the free gift.

I just tried it with my iPhone, and it worked just fine- it seems to have put the Dunes tokens directly into my inventory.

(FWIW, I use Safari on both devices.)


I have the same issue and no they are not getting directly deposited.

Another free gift, another time I cannot access it via my iPad.

1 Like

I tried claiming the coins via my iPhone, and the offer has disappeared from the store. When I tried clicking on the QR code depicted on my iPad, nothing happened. When I used my phone to activate the QR code, the gift was simply not there.

1 Like

Friar Tuck offers free hugs.

FWIW, this week’s gift was downloaded by my phone with no shenanigans.

Tried to use my iPad to get the freebie Epic Hero & Epic Troop tokens that have appeared. All I get is a popup screen with a QR code, so no luck.

Will try again later with another device.

This whole experience is making me glad I’m FTP. How hard can it be to make giving players benefits a seamless, stressless process?

EDIT: and, of course, by the time I could fire up the iPhone, that offer had been replaced by a different one. So, because I can’t get gifts via the iPad, I missed out. Not winning me over.

Ok- it’s more bizarre than I thought:

The iPad still shows a free gift of 100 covenant coins, an epic hero token, and an epic troop token. When I click on the “Claim Gift” button, the QR screen pops up.

When I try following that link by using my iPhone camera, I get to the store and see no free gift available.

I do not have the tokens or that many coins, and checking back, the iPad still shows the gift as available for another 21+ hours.

13 hours left on the gift I can’t claim.

Did you check latest activity in game? It works for me when using my IPhone camera for the QR code on the IPad, even though it is not always showing in a pic that the gift have been recieved.
The QR code leads me to open the game on the phone

It is kinda complicated @BubbaIMHOtep …. You are supposed to go on the Safari version of the website. Then hit the AA button on the left where the web address is. Go to Request Mobile Website from the drop down menu.

Then, and only then, will that darn QR code be gone!

If you are on the mobile website (what you want), then just follow the FAQ or click Claim Gift.

I was the only one in alliance chat with your problem… found the answer in the news and updates area.

Hope that helps. Good luck!!!

Oh and also, I’ve been able to get all the free gifts after doing that workaround (every single time I visit the site). When you load the game, your gift will be there immediately.

Any other questions, please tag me in your reply so that I’ll get an email. Hope it works for you by the deadline @BubbaIMHOtep

Best of luck!

How do you mean? I’ve been playing the game on and of a couple times a day since I posted this thread. I’ve tried using my iPhone several times, including 3x today.