[MASTER] E&P Store Discussion and Help

Anyone how can i delete my card number at ep store?

1 Like

Why we did not get atlantis coins this time ?

1 Like

New Bug: The store dont conect to game: Always a QR CODE appears and never connects

It’s strange that the Store offers (at empiresandpuzzles.com) are more generous than the in-game offers. Fortunately I check both and compare, but I doubt each player does. There’s a store offer of 500 gems for you and 30 for each alliance member, at £2.99, and an in-game offer of 300 gems for you and 30 for the alliance at £2.99. Why penalise those who pay through the game? Equally, for £20, the store provides 3000 gems compared to 2700. It’s a bit stupid don’t you think? Those who check the store get extra gems because they’re making use of the store and the devs are trying to promote it? Please make the offers equivalent and fair.

The online store has a better profit margin than in-game because none of the revenue from online has to be shared with Google/Apple. Therefore, it is in the company’s best interest to encourage money being spent to be through the online store, which is best done by offering better deals there.


The WS store bypasses Google/Apple Platforms saving the company who then passes this savings on to the players.
As far as comparisons…
That’s why we have this

But thanks for looking out for us players, very nice.
May the portals show you kindness!


It’s really strange that you think this is strange.

Thank you. I didn’t realise the financial benefits for the company, in which they keep all of the generated revenue from the store, rather than sharing some with Google/Apple by in-game purchases. Thanks for that explanation :slightly_smiling_face:


Not sure what changed in the online store yesterday, but I’ve been unable to access since then, always getting the following message. I tried restarting my phone, closing browsers and even changing default browser. No dice.

It’s possible it’s just on my side but I’m curious if anyone else is having the issue.

I just checked here, and I can get in.
Using Chrome Browser

1 Like

Thank you @FloKi

I should have added that I tried Chrome, Safari & Edge… using iPhone 14

1 Like

I was able to access it yesterday using Firefox on Android.

Checking …

Still works today.

Edit: I used to get that message using Firefox even though it was set to default, but that was a while ago and I think they changed the website. The default Samsung browser worked then.


It failed to mention that this is Android.
Good luck solving this problem, someone will come up with the solution

1 Like

1)Have you tried the “Use Desktop Site” option in your browser. (The exact phrase may vary between browsers)

2)Have you successfully accessed the store on the same device before? I think a reasonably up-to-date version of android may be required. (May also apply to Apple.)


my alt game is android, didn’t have that prob myself today. but I have gotten that message when I’ve tried to log in and the setting isn’t for the mobile version of the site

1 Like

A million thank yous to all who responded. I appreciate all of the feedback. It helped me to try some settings on my phone I didn’t know were there.

In the end, I was able to get it to work again by clearing all history & data on Safari. Somehow, by doing that, it now works on all 3 browsers again.



using a vpn can also affect things, like what site features you can access for websites and in what deals you can buy in game if your using a balance loaded to your play account or apple wallet vs having your credit card hooked up directly. for anyone else having problems like that


1 Like

I can’t access the store either from DuckDuckGo even when its my default browser I always had to change the defult when I collected untill it told me I could install an app now I just use that.

The problem is the ambiguous term “default browser”. Your phone uses the term to mean "this is the one he wants me to open. And the website is using the term to mean “this is the browser your phone came with”.

1 Like

I use firefox which definitely was not the one my phone came with. Initially there was a problem with the site not recognising it as default browser but now there isn’t. I had to allow firefox permission to open third party apps.