Lost out on mount umber because of bug!

Tried to play each time it sent me to load screen! Missed out on the whole quest because of it! So mad right now I could stop playing!!!:face_with_symbols_over_mouth:

Sorry to hear that, @Darkrayne. I dunno what technical advise to give you on this since I haven’t experienced this specific kind of problem playing the game since May of 2018.

At any rate, if you do plan to quit, kindly make a last ditch effort of you leaving by posting something here: Farewells - MASTER List - Add your favourite past forum great or player who quit [WIKI]. Thank you.

Probably won’t quit because I’m officially addicted but I am enraged atm. I invested alot in this game and have many friends to walk away now. I thank you for your response :blush:

1 Like

This won’t help right now, but any time something like that happens it generally can be resolved on the device side. Try completely shutting sown the game/app. Also, close out of all other apps and check for multiple instances of active browser pagers… anything that might be slowing down your device.

Once everything has been closed, restart your device and open the game again. A fresh start will usually resolve issues like you described - Not always but very often.

Disclaimer: Yes, I know this sounds like a response you get from an IT help desk. Technically, my job position falls under the IT department and I do give out that advice a lot. :rofl:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings