Lost connect in the final stage of Tavern,is this the way you SG add difficulty to it?

My connect to WiFi is solid,and I also open the switch of data in case of unstable network.In this situation,I still randomly see the WiFi symbol in battles,which usually disappear seconds later.But this time,I was going to enter the final stage of Tavern,with my best team,ready to beat the BOSS,and this annoying signal showed up,then I was kicked out from the game.When I logged in again,only to see I lost that battle,and lost my best team,can u imagine how disappointed and angry I was?I don’t know what’s wrong with your server that always disconnct me,and why you guys don’t allow us to get back to that battle,but just define that battle ‘failed’.I think we really need this function in the game,or you can’t kick us off the server while still in battle.

1 Like

Same thing happened to me on the next to last level.

2 Likes

It was the next to last for me and the same thing. My best team, made it to the last phase of the next to last go and the WiFi signal pops up and eventually kicks me out. I was on cellular, sitting in the same spot I had been all day…

2 Likes

Same issue here. Has happened twice. Very stable gigablast connection so I’m sure it’s not the internet.

I also had this happen, but on an earlier level (where the team loss wasn’t as much of a throat punch). Can’t rule it out 100%, but I doubt it was my internet because all my other devices were working fine at the time. As was the rest of my iPad function. Hope SG takes this feedback seriously and looks into it.

1 Like

Now twice ToL has frozen in middle of battle causing heroes to be marked as used and no longer available. Internet connection is extremely stable (gigablast used for office work) and no connectivity issues experienced. Any help?

1 Like

Only thing I could sugest is submitting a support ticket to SG.

1 Like

Cookie Settings