Login problem

Since the last update I and at least one other from my alliance need to connect twice to google play and give empires permission twice for our game info. It is frustrating.

Tried it and cleaned my cache, but it didn’t solve the problem

Btw i run the app on 2 devices and have only problems on 1.

Did you also Clear data?
Is your device connected to Gameplay?

These were the other two steps after clearing cache. :slight_smile:

(If you are still having issues after all of that, I’d suggest contacting Game Support):

https://smallgiant.zendesk.com/hc/en-us/articles/360000542934-How-to-Contact-Support-v1-9-7-onwards-

I did now, on my phone because after my last post it also started on my phone. It seems it also cleared the problem on my tablet. I hope I didn’t loose my link with my beta account though, because I saw I got a new account number on my phone and I don’t know wich of the 2 I gave them.

By the way thanks for the help

1 Like

I usually have to download a new version of Beta every time; if you are having problems then, they are really good about getting you up and loaded. :wink:

Cookie Settings