Latest Update 1/2018


#1

I have a BIG problem with this new update. I’m on my Android phone and now, every time I sign on to play (which is multiple times daily), I see this:

image

Can someone let me know what to do?? And it doesn’t matter if I press Allow or Deny.
Thank you in advance for any help.
1BadNana


#2

Would check your Google security settings / log (if that’s even available to the public interface); sounds like something strange from what little I could google it with their store rather than anything else.

If that fails I’d open a support case with Small Giant.


#3

Go into your settings, Apps, and find the game. Force Stop. Delete Data/Cache.

When you relaunch it should prompt you again, but subsequent launches should be fine. Your game progress will be saved, as its associated to your Google Play account that the game keeps asking you to allow access for when launching.

I had the same issue.


#4

Hallelujah, it worked! Thank you guys so very much!!!


#5

Please edit your post to hide your email address. :fearful:


#6

Fixed. Thanks for catching! :wink:


#7

I have tried several times with cleaning my caches and it didn’t do anything. I’m now getting it twice since I did it. Can you help with that one?


#8

Same for me and my alliance. The android users gets to connect to Google play twice every time the game is opened. Timeconsuming and strange.


#9

@Grandal, @Vigor: Click Petri’s “Permission Issues” thread linked above for the solution. If it still happens after you follow his instructions, please post below.


#10

@Rook, followed directions, twice. Still getting interrupted to sign into Google Play. I have e-mailed Google.
Just dropping a note here and on line. Hope I don’t miss my first Titan.
Sure am glad I upgraded:joy:


#11

Hmm. Have you sent in a request to Game Support yet? (Tell them what you have already done, etc):

https://smallgiant.zendesk.com/hc/en-us/requests/new


#12

Yes, thanks Rook. Waiting for reply.


#13

@Rook I figured out how to get mine to stop. I uninstalled and reinstalled. Only took 3 mins and haven’t had to do it again. It was really getting on my nerves. I had to do something. LOL


#14

So long as your game is saved to Google Play (Android) or Game Center (iOS) first.


#15

It’s very annoying to have to have multiple logins


#16

Deleted cache and date. Reinstalled. Fixed. :+1:t2:


#19

I have the same problem too until find the solution. In this moment it’s fine to mee.
People, do what I said: Go to the app Google Play… Settings … Begin session in auto games …
After, close the every apps and restart the game. After this , never have again problems.
I hope help you guys :slight_smile:


#20

Some of the players in my Alliance had this trouble too. I think Google play had a recent update ? Be sure in your Google play settings that the box is checked next to “sign into games automatically”. This solved my teams mates issues.


#21

Yes, thank you Azure for pointing that out. I appreciate that you did that!!


#22

And Thank You too Rook for taking care of that for me.