Known Issues Related to 1.9 Update

When trying to update to the new version I only get your device isn’t compatible with this version in Google play. I’m running Nexus 6 with 7.1. How can I update?

Please try these troubleshooting tips:

2 Likes

Thanks, this worked, setting the resolution back to normal and clear data and cache. All good now.

1 Like

Still having an issue with this. Keeps saying my device isn’t compatable. I have a samsung galaxy S8. I did all the suggestions. Had the same issue the last time there was an update, and ended up having to download something from Google drive. Is that gonna be a viable option this time too?

Any update on this? Still waiting and still cant play. Its been more than a week!

Have you sent in a ticket to game support? If you tried all the suggestions and it still doesn’t work, I think you need direct assistance:

https://smallgiant.zendesk.com/hc/en-us/requests/new

I also am having the same exact issue which happened in 1.7 as well this time its been almost 2 weeks now of not being able to play

Submitted the ticket a week ago as well no response yet

Be aware:

A post was split to a new topic: Lost Diamonds

Cookie Settings