KNOWN ISSUE: Video ads (Mystic Vision) don't work (Main Topic: Crashes / Unavailable)

New posters, did you fully turn your phone off and back on? That has worked for several of us above.

1 Like

When trying to watch the Mystic Vision (ads), I get this error…

I’ve had the same error, but not during the last few days.

I just had it too restart phone worked.

2 Likes

mystic visión buged, got storage, last versión and restart the Game, 12h waiting, thx.

Restarting my tablet worked. Not sure why.

1 Like

I’m having this problem too, AFTER I restarted my phone. Will try another restart.

EDIT: Restarting again fixed the problem. :wink:

After waiting for the time for Mystic Vision to regenerate, it says not available. Tried logging out/in, shutting down/restarting my device, nothing seems to affect it. So far I wait another 2 days and it will work randomly. Noticed the closed threads but no fix available in the closed threads. What to do. What to do.

2 Likes

Contact SG directly, including a screenshot of your error message:

https://smallgiant.zendesk.com/hc/en-us/requests/new82

There’s a lot of closed threads because of me :smile: I collect them here so it all ends up in the same place.

Please scroll up to the second post in this thread that Petri wrote. Hopefully one of these fixes will work for you.

Hello, I’ve been having problems for 4 days to watch the videos. He always gives me a mistake and tells me to try it later.
I tried rebooting the internet, restarting the mobile and nothing at all
Any solution? because they are many gems that I am losing
Thanks

Did you already try to de- and reinstall the game? A member of my alliance had the same problem and could solve it that way. Just make sure you saved your game via Google Play or so…

thanks, reinstalling has solve the problem

1 Like

Doesn’t work since this morning and reinstalling the game doesn’t help. Same on my both accounts. Please fix it. empires

1 Like

Same thing second day… Solutions would be greatly appreciated.

I have moved your post to another thread on Mystic Vision (video) issues. Scroll up to the third post in this thread. Petri has possible solutions for you here. :slight_smile:

Anyone have any other solutions? @Coppersky?

Hi all,

I’ve had an isue for the past week with Mystic Vision. It’s won’t play the video “please try again later”.

Has anybody any ideas or updates on this.

Many thanks

I have been getting the same problem too.

Have had it previously, only resolution I found was restarting the phone in my case.