[KNOWN ISSUE] Titanium Shield in battle text is missing

I used a Titanium Shield during Tower of Styx.

When I wanted to check how much turn is left (1 on the screenshot), then I noticed that it’s buff description text is missing.


I had a weird glitch text like that be for but it was for Grimoire Dust and it said something with (dragon.season.1) And I had a picture of it but don’t know we’re it went. And when I saw the glitch text on were to find it the only thing I could think of is the “Domain of Dragons” that is being worked on. And that was the only item with the glitched text on where to find it that I could find before the fixed it.

Staff has these constant placeholder texts everywhere, which are replaced with the actual text in the selected language.

Seeing such text what I posted above means that they do not have the English (or other language) translation for this string constant.

1 Like

As I see Staff has just marked this as known issue so it seems they see the problem too.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.