[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

So the latest patch to fix the War issue has at least added the error message that my payments have been disabled. Now I don’t get the endless spinning wheel. I also DONT get to purchase any gems as this is Not an issue on my end that is fixable. I am not the only person experiencing this and it started after the last update so developers you do the math and fix the issue please.

1 Like

My Challenge Event Gem Off has disappeared and my Shop has been ‘loading’ for best part of a day. Is anyone else experiencing this?

I can’t even give my money away.

Derric, you are now stuck in limbo with the rest of us. Empires says it’s our fault and/or Google’s. Google says it’s our fault and/or Empires. Sorry to break it to you. There’s no fix. Keep following the thread and maybe someone will eventually find a fix. Thanks :slight_smile:

…and to think…I started this on the 6th of May and it’s now June and SG keeps giving all you guys the same excuse they gave me over a month ago…smh…

When they start noticing their profits dwindling…they will find a fix…right now it’s not important to them

Hey folks, do any of you use a Samsung device? If so, one person fixed theirs by going to Samsung shop and updating Samsung Experience. Can be checked thru settings also. Some Samsung updates only thru the galaxy app store and not Google play. Don’t know if that’s the issue you are having, but trying to share the word in case someone reads this and it helps.

1 Like

I think most of us have Samsung devices, so I’ll definitely check this out. Thank you so much!

HOW MANY PEOPLE HAVE GOOGLE DEVICE POLICY INSTALLED ON YOUR PHONE? I think this may be the issue.

I have it on my phone but don’t think that it is enabled…

Kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk can’t give my money away. Kkkkkkkkkk best post ever

Grell65, I don’t think it matters. Try erasing it off of your phone. You need to get rid of it entirely.

Did that fix your problem?

I can’t disable mine because of the email I’m using, but others might see if it works. We tried it with my husband’s account on a laptop and it disabled purchases when the device policy was on the laptop, but when it was removed, he could make purchases. He hasn’t had any issues with his account or phone, we were just using his account to test the theory.

1 Like

Erased mine restarted and same result. Purchases are disabled on your device MEGA BS. SG broke it SG needs to FIX IT!

Any word on SG as to a fix for this!?! It’s going on a Month now …

No… And this issue started with sg update…

When I enter the gem offers page in the app, it says “loading” and keeps loading forever. I cant purchase any gem packs.
Also during wonderland event i did not receive the regular 200 gems for 1$ offer. (might be related)

playing on android, if it makes any difference

Do you by chance have an older model Samsung phone, like an S6?

Mine is an s6. Will probably upgrade soon, but was hoping to fix issue first

That make perfect sense. I was curious if @arathemis was in the same boat on the phone front. FWIW, my S8+ seems to work fine, so it definitely doesn’t need a latest generation Samsung.

No. I have a xiaomi note 4. It worked fine till about 1 week ago

Cookie Settings