[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

Bluestacks is simply an Android emulator. If you can get the shop to work on Bluestacks, then it sounds like there’s some issue with your phone.

That said I’m glad you’ve found a workaround. I’ve been checking periodically with staff to see if they had any new ideas. They haven’t been ignoring the problem, but they genuinely haven’t found anything on their end that could be a cause.

1 Like

I play on a tablet and its still stuck in loading mode, so It cant be the phone.

1 Like

Are you saying that using the same account on both a phone and a tablet, the gem store is stuck loading for you on both of them?

If you follow the steps I took and supplied above, you can purchase gems. Then go back to your phone or tablet and use the gems afterwards.

Hi all. About 4 days shop is not working.


Thank you

1 Like

How did you fix it? Please tell, have a friend with this same problem

I tried all the way in this topic. It was not work. I am sorry . I need help

I’m having the same problem. (Android user, problem since last update) I’ve tried everything. I was also told it was a Google play issue. I made sure to check all my payment info, everything is correct. I’m hoping this issue is resolved on next update. I also didnt get the Atlantis flash offer. I usually do a 10 pull each Atlantis summons but wasn’t able to this time.

You can not fix it on your phone but you can download the bluestacks installer on your computer and run the installer AND THEN download empires and puzzles on your computer and play thr game or just purchase gems on your computer and then open up the game on your phone and your gems should be there…click on the link and scroll down on the page that opens…and follow the directions on that page to get everything you need to play and purchase gems in the game…


Following the directions above

The link is above…follow those steps on the linked page

I tried it but it isn’ t working on me. I tried another acount and same problem. On phone or on PC emulator. I think tthe game don’t need my money :frowning:

Thank you so much! I’ll let my teammate know.

So, yesterday I spent almost 2 hours on the phone with Google and they could not fix the issue! I had already contacted E and P and they said to contact Google (oddly enough, about 1.5 hours in, they told me to contact E and P). So, it’s pretty useless either way. If anyone finds a solution, please post for us poor, desperate souls dying to spend our hard-earned cash :slight_smile: TIA!

Hi guys. Finally i found a solution. Update your play store.

  1. Open the Google Play Store app.
  2. Tap on the menu icon in the upper left-hand corner.
  3. Scroll down to Settings and tap on the link.
  4. Scroll all the way to the bottom the list; you will find Play Store version .
  5. Single tap on Play Store version .
  6. You will either see an on-screen message confirming that your Play Store app is up-to-date, or the app will silently start updating in the background. When the update is complete, you will receive a notification.

Good luck

1 Like

I am up to date and STILL have this issue! This is ridiculous I want to spend money!

i don’t receive money offers on my account,i’m waiting for solutions,when I go to the shop it says LOADING and nothing appears on the main screen (offers to buy)

Welcome to the forum @Cezannes. No one is quite sure what is causing this issue. SG believes the problem is somewhere on the user’s device or with Google, and Google apparently believes it’s an SG problem. At any rate, there’s no known fix.

However, @Booracle has found a potential cause of the problem for some people, along with a solution, here:

And @Juzjokez has found a potential workaround that seems to function for some people here:

V21 Issue: Gem store not loading [Master]

Hopefully, one or the other of those posts will help you address the issue.

I did everything above and it does not work,thanks anyway

One of the first things I did was check Google update, play store updates, etc. Nothing works

Cookie Settings