[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

Well, I guess posting about it here is just as pointless as opening a support ticket, since the forum is moderated by players, not game developers. :woman_shrugging:

2 Likes

@Garanwyn SG Support keeps saying it’s a Google play payment issue. It’s not. I can make purchases in other games, and Google support says it’s a game issue. It’s not a purchasing issue if the screen I need to access in order to purchase something in the first place doesn’t load. Clicking on “Shop” and “gems” opens a screen that looks like this:

1 Like

As long as SG keeps referring me back to the forum to ask if anybody else has this same issue and can help me solve it…I’ll keep making new bug threads. If you do not agree with it, take it up with SG. Obviously I’m not the only one having this same issue yet they keep telling me and others that it’s a Google play/credit card issue. We dont make these threads to make it hard on moderators, we make them because we have issues that need resolve and nobody is taking the time to figure out the problem.

If they actually took the time to figure it out instead of telling us to come back here and ask…you wouldnt see multiple bug threads.

2 Likes

So, you’re saying that in the email response to your support ticket, SG referred you back to the forum?

Exactly…

If they told you it’s a Google Play/credit card issue, why would they refer you back to the forum? That would seem, more properly, to be an issue addressed by Google Play support.

They’ve sent me multiple emails with different possibilities of the remedy for the issue

This is one…

" In general, technical issues affecting the game are not limited to a single account, but if there were a bug, it would affect a significant amount of accounts. In these cases, the issues are noticed quickly by both our team and our players, who report them to us through the Forum and Support System.

Any known issues regarding the game are posted on the Announcements page of our FAQ and on our Community Forum."

1 Like

Ok, that is NOT referring you back to the forum to ask if anyone else can help you solve the issue. In fact, that’s not referring you back to the forum at all. It is merely pointing out that issues which affect may other people tend to get lots of unique posts on the forum.

The way that staff notices that an issue has some broad effect is that there are multiple posts by unique individuals all in one place – which is why I’ve collected up the disparate bug reports on this issue into a single thread. That will help them see that multiple people have the same problem.

Multiple threads just makes it harder for SG to see how many people really have a problem. And it’s also against the forum rules. So please don’t keep spamming posts on the subject.

I will send a message to staff to see if they have any more insight on this problem that they can share.

1 Like

Thank you kindly…

Make sure you point out that I’m not the only one in the forum with this issue please.

1 Like

I promise I have. Just remember, all I can do is ask and suggest :slight_smile:

There should not be any known issues related to in-app purchases. However, we will investigate this from our side as well. Usually this happens when either the purchases have been disabled from the device settings or the payment information is incorrect. As Apple and Google handle all the in-app purchases towards the game, players should contact them for further assistance.

2 Likes

Even if purchases are disabled that wouldnt stop the shop page from loading. As soon as you click on the “shop” tab at the bottom of the screen, it goes to the shop page but it stays stuck “loading” the screen before you can even choose what you want to buy in the shop.

3 Likes

I am also having this issue. It’s not a purchasing issue. My purchase options are not disabled. I can make purchases in other games.

The issue is with the gem screen. It is stuck on the load screen. I don’t even get the option to purchase gems because the screen wont load.

I’ve reached out to support numerous times and they keep saying the same things: check with Google Play settings, check to see if other players have solutions, check wireless settings. And so on. None of these solves the problem. That’s why I and other people with this issue are so frustrated.

When I click shop > gems I see a loading screen (see screenshot). I dont even get the option to purchase, so dont see how this is a purchasing issue.

It’s not just me. I just so happen to go in Google play and look thru reviews and seen a few people complaining about the shop screen being stuck loading and cant purchase gems. I also see the SUPPORT keeps telling them the same thing they told me “Its not a bug/its a Google pay issue/its a credit card information update issue”.

They lied to me and told me nobody else were having this issue with the shop screen being stuck in loading yet I see others with the same problem.

A few customers with issues wont hurt their pockets so they blow us off with the same default emails but I guarantee if thousands stop purchasing gems they would break their necks trying to figure out why.

You simply dont treat paying customers like that. It will eventually go bad for you when you do.

Screenshot_20190515-004829_Google%20Play%20Store

Smh…I just did this to show all you moderators that’s it’s a REAL issue and the company is doing nothing to fix it since it’s so few having this issue.

1 Like

So no news on this issue?

Every time I go to the shop to purchase gems it will not move past loading. I tried restarting the game I tried signing out and back in Nothing… Can someone please help me out. The Gem shop is stuck with a loading screen.

Cookie Settings