[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

Actually, if you hit the “Support” button, it takes you to support.smallgiantgames.com

If you hit the “Report A Bug” button, it takes you to the forum.

You want to hit the “Support” button, then when you get to the website click on the three horizontal lines in the upper left corner:

That brings up the menu option to submit a request.

I have tried all of these, and it is not helping me.

Additionally, I have:

  • Unistalled and installed the game 3 times
  • Triple checked my Google Play account setting and payment options
  • Tried both on and off of wireless
  • Cleared my phone’s cache

This problem started with the Version 21.0.0 Build 1008 download. Prior to the download, I was able to access the gem screen and download fine. Now it’s stuck on a loading page.

I’ve submitted a support ticket, and they are telling me it’s not a known issue and is a problem with Google Play payments. It’s NOT. It’s also not a problem with my phone (Samsung Note 9+)

Is there a fix for this or not? If not, then I guess I won’t be spending any more money on your game.


Still waiting on a solution for this. I’m also not getting any popups when I start the game, advertising deals of the day and heroes of the month.


I don’t know what to tell you. I and the other moderators are just players like you, so there’s nothing we can do to fix the problem.

SG support, who you’ve been emailing with, are the ones who can actually address account problems. If they told you this is a known issue with Google Play payments, how did they advise you to fix it?

Anybody else having problems with the gem tab stuck loading?

Please dont say it’s a credit card/update information issue because its not. I cant even get to a credit card option screen because as soon as I click on “Shop” it gets stuck loading the screen/page.

I’ve tried it all…turning phone off for 15 min…logging off…deleting old credit cards…submitting a ticket and they keep telling me it’s not a bug because nobody else has complained…smh


There is definitely a difference between that tab and all the others. I live in China which means that certain parts of the internet are blocked unless I use a VPN on my phone. If I go to the store without a VPN the gems tab won’t load, it just constantly says loading… The other tabs work perfectly, even without a VPN.

Another (probably) related issue is that the game only shows me special offers if I log in with the VPN turned on. That all leads me to suspect that the game is contacting a different server or something when it comes to gem related stuff.

If you’re not in a country that censors the internet, it could still be an issue caused by that.

I realize this problem is frustrating, but you can’t keep opening new bug threads on the same issue.

What does SG recommends about the shop being stuck on a LOADING screen when attempting to purchase gems?

This has been like this for over a week now

1 Like

@Juzjokez Did you ever submit a support ticket?

Did all of that. They still havnt fixed the issue. Submitted more than one ticket also. Seems like they would have somebody in the forum that could help with these sort of issues as a backup

The forum members are just players like you and me, even the moderators. So these kind of issues can only be solved by the developers. So support ticket is the best way to go about it. :slight_smile:

Agreed–that would be super helpful.

As far as what SG has recommendations for, all I do is check here:


You can click the tabs to see various topics. Also, if you scroll down, the “Promoted Articles” section has posts on recent issues.

Also-- I’m not sure opening multiple support tickets on the same topic is going to get anything solved faster…

Different tickets opened under different topics. Just to make sure they got it. They dont have a specific default complaint tab for “shop loading screen stuck in gem tab location” so I done topics that came the closest

I’ve submitted a support ticket and searched the forums here, and have yet to see an answer.

When I go to purchase gems, the selection screen won’t stop loading. It hangs, and I’m unable to select a gem option to purchase.

This is NOT a problem with the actual money transaction, which was support’s suggestion. This is a game flaw.

I’ve uninstalled and re-installed the game, and I have the same problem.

See the attached screenshot for more info.



Same has happened to me and they keep thinking I’m talking about a payment issue

1 Like

Yep, it’s super annoying. Obviously it’s a bug and a known issue. Youd think they would want to make sure players can spend money on their game.

1 Like

I’m also not seeing any ads like I used to. Usually I get pop ups to purchase packages or spend gems on heroes.

1 Like

When I access the Shop, I’m unable to purchase gems, it’s stuck on a “loading” screen and the gem options are showing "currently unavailable. I can access the other sections (resources, battle items, featured) just fine. Any suggestions would be appreciated. Thanks!


Humm legal, essa sao umas das q eu observei

1 Like

Mine is doing the same. Do you have Samung or any android device?

Cookie Settings