[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

I have the same problem and have the same phone as you.

We’re still investigating this from our side.

In the meantime, please try the following troubleshooting tips:

  • Try emptying the data and cache from the Google Play Store App and also from the Game.

If this doesn’t work, please try the following steps, as they have helped others with the same issue:

  1. Remove all Payment methods from Google Play
  2. Restart your device
  3. Add your desired payment method again
  4. Launch Empires & Puzzles.
3 Likes

I am having the same issue, I have an Android and the gem store refuses to load. My version is 22.0.0. I’ve also noticed the “deals” that normally show up aren’t anymore since the issue started. I’ve contacted support and have done all they’ve asked so far:

  1. Restarted device
  2. Uninstalled/Reinstalled the game
  3. Cleared data and cache for Google Play Store and the game
  4. Removed all payment methods, restarted device, added the payment method again

One thing I should note: I was recently traveling in Europe (I’m from North America), and so could not play this game with Mobile data, only on WiFi. On June 27 I accidentally opened the game when there was no WiFi, I quickly closed it. I started having this issue the next time I opened it in Europe when I did have WiFi. The problem has persisted since returning to North America. I don’t know if anyone else had a similar experience when their problem started, having bad cell signal or no WiFi.

What is your country set to for purchases?

I have a samsung 9s+

Screenshot_20190701-181923_Empires

I cant purchase any gems. It has been frozen for days.

Ive force stopped the app, cleared cache and data for E&P, cleared cache and data for google pay/play/and games apps. Ive restarted and removed payment options in google play store.

Im not sure what else to do.

1 Like

Nope. It was already up to date

Just lost my gem store on my iPad. It’s there on my iPhone but not the iPad. It was there earlier today.

I’m experiencing the same exact issue as everyone else. Samsung Galaxy S6.

Any fixes yet? Kinda scary that this issue has been going on for this long.

My gem section isn’t loading at all

Tried all of that. Still doesnt work.

In my ally there’s a member with the same issue. He tried the typical things, closed the app, force the detention…
But nothing works and the issue still remains.
Too sad.

1 Like

My gem store is back!!

Update*** The Gem Loading screen has gone away!!!

I am able to see all seasonal offers and gems available to buy.

As for what I did. Unfortunately, I’m not exactly sure. it happened randomly. I did everything in this thread including bluestack which I made a purchase on.

Gem store has been broken for me for over 3 days.
Samsung S 6

My country was set correctly to the US, I had already checked that. However, the issue just resolved itself suddenly today! I still don’t know what caused it, or how it was fixed, I didn’t do any additional steps than what I listed above, it just suddenly started working today?

1 Like

After 2 months…its finally working again…

I just so happen to power cycle my Samsung Note 8 and the gem shop works again…

Dont know if it will work for you guys but…power cycle your phone and see if that helps

Still not working over here. Almost 2 months now

Been months now no help in sight…so frustrating…

I hope that this will be addressed in the next patch because it sure isn’t being fixed in the short term just a lot of useless feel good suggestions and blame game. The bottom line is nothing changed except for the patch and THAT caused it to break.

It seems for most players updating the Android software (that was released a few days ago) of their device has helped to resolve this issue.

2 Likes

Cookie Settings