[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

Following the directions above

The link is above…follow those steps on the linked page

I tried it but it isn’ t working on me. I tried another acount and same problem. On phone or on PC emulator. I think tthe game don’t need my money :frowning:

Thank you so much! I’ll let my teammate know.

So, yesterday I spent almost 2 hours on the phone with Google and they could not fix the issue! I had already contacted E and P and they said to contact Google (oddly enough, about 1.5 hours in, they told me to contact E and P). So, it’s pretty useless either way. If anyone finds a solution, please post for us poor, desperate souls dying to spend our hard-earned cash :slight_smile: TIA!

Hi guys. Finally i found a solution. Update your play store.

  1. Open the Google Play Store app.
  2. Tap on the menu icon in the upper left-hand corner.
  3. Scroll down to Settings and tap on the link.
  4. Scroll all the way to the bottom the list; you will find Play Store version .
  5. Single tap on Play Store version .
  6. You will either see an on-screen message confirming that your Play Store app is up-to-date, or the app will silently start updating in the background. When the update is complete, you will receive a notification.

Good luck

1 Like

I am up to date and STILL have this issue! This is ridiculous I want to spend money!

i don’t receive money offers on my account,i’m waiting for solutions,when I go to the shop it says LOADING and nothing appears on the main screen (offers to buy)

Welcome to the forum @Cezannes. No one is quite sure what is causing this issue. SG believes the problem is somewhere on the user’s device or with Google, and Google apparently believes it’s an SG problem. At any rate, there’s no known fix.

However, @Booracle has found a potential cause of the problem for some people, along with a solution, here:

And @Juzjokez has found a potential workaround that seems to function for some people here:

V21 Issue: Gem store not loading [Master]

Hopefully, one or the other of those posts will help you address the issue.

I did everything above and it does not work,thanks anyway

One of the first things I did was check Google update, play store updates, etc. Nothing works

@Cezannes, @halcat have either if you, by chance, tried clearing the caches on Google Play and Google Pay?

I know that sometimes bad data can get stored in caches which prevents programs from working correctly.

If you do decide to try this, I’d probably make sure I’d exported my payment data and was prepared to re-enter payment method info, because those could get erased by clearing the app and data caches.

1 Like

Yeah, I did that. Also, Google support had me try that, as well, when I called then. Thanks for the tip, though. I really am at my wits end, so any suggestions are greatly appreciated :slight_smile:

1 Like

Sure thing. I really wish I knew how to help. I’ve followed up with SG staff a few times, and they have told me they’re still looking from their end, but they genuinely don’t see how it can be their issue at this point.

I tried toggling all of the settings on my Google Pay to see if one of the opt-outs might cause the behavior, but none of them did. I’ve tried unlinking my cards and going to the shop. Basically, nothing I could think to try on my phone replicated the problem, so I’m out of ideas. If something clever strikes me, I’ll definitely let you know.

Thanks, Garanwyn :smile: It’s just so frustrating after almost a month and more and more members encountering this issue

Just installed the latest update. My gem store is still loading. This is bs

Yeah, I was also hoping it would fix it :frowning:

Garanwyn, thanks again for trying to resolve our issue.

I’m hoping maybe a Google play update will fix it. However, it is interesting it started happening after Empires update around May 9

1 Like

I too have this issue since the update. Tried ALL solutions but NO SOLUTION c’mon sg this is your money your losing. FYI S7 Samsung edge phone.

What phones does everyone have? Samsung Galaxy S6 here

samsung S7 edge for me

Cookie Settings