[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

Did you contact the Support?

I have the same problem. Anybody van help me. Please

The Gems store is stuck in loading?!?!?!?!

1 Like

This is quite old, but it has suggestions for addressing what sounds like the same issue:

Try first:

Additional ideas:

(@Kerridoc @Rook @Coppersky Possible Merge of Topic)

Thank you. The problem is fixed but I swear to God I sometimes HATE this game it’s so unfair. I really needed an orb of magic & it was available with an ascension pack, I bought it & got NONE. I don’t understand how I’m supposed to ascend my hero if I can’t get the ascension items needed. It’s completely frustrating

You’re welcome, and glad it’s fixed!

There are two guaranteed (and free) ways to get an Orb: the Shiloh Desert Rare Quest, and completion loot for the Epic and Legendary tiers of some of the Challenge Events.

Both of those are hard to complete for newer players. For me personally, it took around 4 months before I could manage to consistently finish them all and get the ascension mats from them.

In the meantime, 3-60 4* heroes, and maxed 3* heroes can get you pretty far in the game. Then you just have to have patience to get ascension mats like orbs at random from Titan loot, chests, or even Mystic Vision. It’s a slow process, for sure, especially at first. As you slowly level up, it becomes easier to get mats from guaranteed sources, and to get better loot from titans.

@General_Confusion put together a nice guide on places to get ascensions mats that goes into more detail:

It’s also helpful to know how Titan loot works:

1 Like

come over to my alliance we get them all the time. it’s a smaller alliance and a drama free relaxed game playing experience. or find a higher alliance to defeat higher titans for the loot

1 Like

I think there is something wrong. It’s been like this for days now.

1 Like

That doesn’t look correct as mine is available. Have you tried shutting down your game and restarting your device?

Hi @Juzjokez, since this seems to be a recurrent issue that several people have, I’ve designated a master thread and moved your post to it.

This post above, by @zephyr1, has good advice on how to handle the problem:

1 Like

Shut the game down and restarted. Still no change

Nope. Still not fixed

Well, sounds like all that’s left then is #3 on that list: opening a support ticket :slightly_smiling_face:

That or they look into the problem. The longer they take the more money they save me lol. It’s a win win for me.

The forum isn’t set up to deal with individual account issues. There’s no connection between forum information and player accounts.

I’ve grouped the reports together so that the devs can see it’s a persistent issue–but submitting a support ticket will actually let them see an example of the problem so they can figure out how to fix it.

Ok thanks…

1 Like

Funny how I hit the “support” button in the game to report the bug …it sent me straight to the forum.

Actually, if you hit the “Support” button, it takes you to support.smallgiantgames.com

If you hit the “Report A Bug” button, it takes you to the forum.

You want to hit the “Support” button, then when you get to the website click on the three horizontal lines in the upper left corner:

That brings up the menu option to submit a request.

I have tried all of these, and it is not helping me.

Additionally, I have:

  • Unistalled and installed the game 3 times
  • Triple checked my Google Play account setting and payment options
  • Tried both on and off of wireless
  • Cleared my phone’s cache

This problem started with the Version 21.0.0 Build 1008 download. Prior to the download, I was able to access the gem screen and download fine. Now it’s stuck on a loading page.

I’ve submitted a support ticket, and they are telling me it’s not a known issue and is a problem with Google Play payments. It’s NOT. It’s also not a problem with my phone (Samsung Note 9+)

Is there a fix for this or not? If not, then I guess I won’t be spending any more money on your game.

3 Likes

Still waiting on a solution for this. I’m also not getting any popups when I start the game, advertising deals of the day and heroes of the month.

1 Like