[KNOWN ISSUE] Shop Not Loading for Some Players on Android [Master]

Did u get it fixed??

DID u get it fix yet??

I think mine started in the beginning on May. I play on Android. When I had to do like 3 updates in a row.

Same here! Submitted a ticket… No solution! Has been a problem since the last update

Ok people…I found out the problem.

The problem seems to be only effecting ANDROID phones so it’s something in the current build that’s keeping the shop in loading mode when you attempt to purchase gems.

I found a way around it but it requires a little effort and time invested.

If you want to make purchases, you can download an app installer onto your computer (PC or MAC) and then download the app onto the platform.

These are the steps I took.

Step 1 Go to this link and download the installer to your computer …https://www.bluestacks.com/apps/role-playing/empires-puzzles-rpg-quest-on-pc.html

Step 2 After installing the Bluestacks installer on your computer, open up the installer and let it finalize everything.

Step 3 Go to the app center and download empires and puzzles if it’s not already there inside the app center.

Step 4 Click on the app and let it load

From this point it should ask you to sign into your Google account so it can set it up in the app center just like on your phone and afterwards you can either play the game just like you do on your phone or go straight to purchase gems and then sign out or open your phone up to verify gems are now on your game.

It worked for me and it should for your…now hurry up and go get those Atlantis heroes you’ve been wanting lol…

GOOD LUCK!

2 Likes

Bluestacks is simply an Android emulator. If you can get the shop to work on Bluestacks, then it sounds like there’s some issue with your phone.

That said I’m glad you’ve found a workaround. I’ve been checking periodically with staff to see if they had any new ideas. They haven’t been ignoring the problem, but they genuinely haven’t found anything on their end that could be a cause.

1 Like

I play on a tablet and its still stuck in loading mode, so It cant be the phone.

1 Like

Are you saying that using the same account on both a phone and a tablet, the gem store is stuck loading for you on both of them?

If you follow the steps I took and supplied above, you can purchase gems. Then go back to your phone or tablet and use the gems afterwards.

Hi all. About 4 days shop is not working.

Screenshot_20190524-225326_Empires

Thank you

1 Like

How did you fix it? Please tell, have a friend with this same problem

I tried all the way in this topic. It was not work. I am sorry . I need help

I’m having the same problem. (Android user, problem since last update) I’ve tried everything. I was also told it was a Google play issue. I made sure to check all my payment info, everything is correct. I’m hoping this issue is resolved on next update. I also didnt get the Atlantis flash offer. I usually do a 10 pull each Atlantis summons but wasn’t able to this time.

You can not fix it on your phone but you can download the bluestacks installer on your computer and run the installer AND THEN download empires and puzzles on your computer and play thr game or just purchase gems on your computer and then open up the game on your phone and your gems should be there…click on the link and scroll down on the page that opens…and follow the directions on that page to get everything you need to play and purchase gems in the game…

2 Likes

Following the directions above

The link is above…follow those steps on the linked page

I tried it but it isn’ t working on me. I tried another acount and same problem. On phone or on PC emulator. I think tthe game don’t need my money :frowning:

Thank you so much! I’ll let my teammate know.

So, yesterday I spent almost 2 hours on the phone with Google and they could not fix the issue! I had already contacted E and P and they said to contact Google (oddly enough, about 1.5 hours in, they told me to contact E and P). So, it’s pretty useless either way. If anyone finds a solution, please post for us poor, desperate souls dying to spend our hard-earned cash :slight_smile: TIA!

Cookie Settings