[KNOWN ISSUE] Issues receiving rewards from Mystic Vision (Android)

Watched the video twice for the full time but once completed unable to close and return to game. Upon force closing twice but closing game…returned to still no reward and Mystic Vision still shown as if it does not recognize video watched twice. Hoping this is corrected soon. I only watch the ads for the rewards! Anyone else having this issue?

7 Likes

I have the same issue! It homescapes video for me if that is important.
Watched mulitple times, game freezes afterward and cant exit the video :confused:

I have the Looney toons ad. Pacific time. It is glitching for me, as well

@Kerridoc should we contact the support or is this issuse known?

Is this a specific ad?

@Petri My ad is always the same one, for homescapes, but @Cuckoobirdhero seems to have an issue with different one. Buttons can be pressed at the end of the ad, but nothing is happening. Only way is to shut down the game and restart it

Tried again, this time i got different ad, but the problem persists

2 Likes

I had AFK Arena so it appears it’s not the advertisers fault; it’s Small Giant’'s fault.

I’m sick of all the excuses and apologies; they mean nothing to me. If you’re going to say sorry, say it with flasks, say it with trainer heroes, say it with Talent tokens.

Stop being so :baby_chick: cheep :baby_chick: cheep :baby_chick: cheep!!!

1 Like

My husband is having the issue with having mystic vision freeze, regardless of the ad - different ad after he rebooted his tablet.

I’d searched the forum to see if it was an issue but at that time no one was complaining about it. He submitted a support ticket.

@Petri my mystic vision is fine and my husband and I both use a Samsung tablet, and same internet provider, plus our games are updated, if that helps at all.

Having the same problem here. I tried 4 times and each time l get stuck at the end of video. I can’t close the video screen, neither get any gifts.

having the same issue as well, depends on the ads, once its completed, unable to close and return to game for reward. The “X” button does not register when clicking it.

Ads that work -

WWE Smackdown ad

Ads that are stuck

Sea game
homescape
hero wars
looney tunes
Battle warship: naval empire

(I have many alt accts :smile: )

Same here, but with AFK arena. Watched it few times, rebooted phone…

I have been experiencing the exact same issue for the past 24 hours

Idk if this is the right place to post it but I had issues with my mystic vision like can’t close the video or watch it at all (X) on the play icon… Seemed like the game conflicts with my VLC player (on android)…

Hi there,

I can click to view and watch the ad for Mystic Vision, but after the ad is finished, it will not allow me to close the ad and receive the rewards. I constantly have to manually close the game and open it again.

Mystic vision will be available again, Il play the ad, and when its done I cant close. This occured for the past 24 hours.

Can you please advise?

Screen name: Melhunter1913

That’s happened in the past to me as well. Like months ago, more than once. Developers usually catch-up with the bug within a day or so.

1 Like

Hi @MelHunter1913. Unfortunately, the forum isn’t set up to deal with individual account problems. That’s generally handled through support tickets. That said, thank you for posting about the problem! This way, if other people are having the same problem, SG will be able to see the scope of the problem and deal with it.

Here’s the SG advice for game crashes. I realize you’re not having a crash exactly, but something in there might be helpful:

If that doesn’t fix the problem, I’d encourage you to open a support ticket. Here’s how to do that:

1 Like

Players have been reporting on it all day on this thread

@zephyr1

1 Like

I am having the same issue with mystic vision

I had the same issue, but it appears to be resolved now - try it again and see.

Cookie Settings