[KNOWN ISSUE] Freezing - Unable to finish a level in Pirates of Corellia (Oct 2019)

Hello, today I was playing level 10 of Legendary and doing excellent, I was going to get a super high score until the game freezed, and I could not press any button, only the “autoplay” however it did not so anything. I could not finish the level and I lost the 6 flags!!
It was super unfortunate because I was going to get an excellent score, besides that, I used a flask to go quicker through the levels and I lost the 6 flags. It would be nice if you give them back. My name in the game is ierazo.
I’m attaching photos. I took the first screenshot more or less 1 and half minutes after the freeze started. Before I tried it to work to no success. I tried everything, I logged into others apps but nothing happened until I had to actually close Empires.
I guess that I am not the only one that had this problem and I expect you to fix it so nobody else has it!!

1 Like

I just experienced this in Epic Level 10 - I just need 1 or 2 more moves to kill off Marie Therese in zombie form and now I’m just stuck… It froze about 4 minutes in. It’s at 18 minutes and I still can’t make a move.

thank you for reporting, we are looking into this now.

2 Likes

just happened to me as well, exact same as OP. epic, level 10

I took a video of this. I had the exact same problem.

Hi Forum, I’m able to do everything in game, but fight in the event. I was able to purchase and even do a 10 pull. But it locks up in both rare and epic so far.

Help

Seems to be happening to me. Though to be fair, in the past couple of days, I have been having connection problems. Either the load screen loads, and then hangs. Or when i am trying to conduct a raid or event the game will hang. Running 23.0.1 build 1117 on android.

@zephyr1 @Rook @Garanwyn

1 Like

Merged, thanks! :heart_decoration:

1 Like

On Pirates of Corellia Epic 7 the game froze. Only button I could press was auto. The button highlighted but nothing happened. I could press it to turn auto on and off but no tiles or other buttons worked and the timer was still increasing. Unsure what to do as do not want to lose more flags if I encounter this problem again.

@zephyr1 @Garanwyn @Rook

Same bug as here:

1 Like

Merged, thanks! :heart_decoration:

I got to level 10 in epic was playing fine, extended it 4 times using gems after being defeated, right after the 4th extension, it just stops letting me do anything, I could click the monsters or probably used a hatchet or life saving potion if I had any left but it wouldn’t let me move gems into rows or continue playing… I finally had to shut it down, really disappointed after spending 450 gems to continue only for it to do that, not sure I want to spend anymore money on this game after all that time and gems wasted only to not complete the level! Truly disappointed!

Same here. I had to restart the game two times. Using Gretel on one of the bosses that turns into another guy with lesser health, when that other guy gets full mana with Gretel special on him, the game freezes. Dont use Gretel and you should be fine.

Actually that is very insightful.

The issue happened on Epic, Stage 10. hit with Gretel.

Wondering if each of the users here had a mana-control hero in their lineup?

(also: This really should be fixed.)

Happened to me yesterday & was using Hansel.

1 Like

I have had this happen a few times. The most recent on was on the final level of the Epic stage and I had actually used gems to extent the fight because I was tired of losing. Game froze when I had the last boss down to a sliver of health. Really not cool that I lost gems on on a attack that froze up.

I was using Gretel too. So that’s a commonality. Seems like all of the reports include either Hansel or Gretel.

Note to self: Do not use Gretel on zombies. I can’t not use Gretel on the rest of it since she’s my favourite available mana controller

I used her anyway. Did alright after a couple tries

I don’t have either Grendel or Hansel. But things seem fine for me now

Cookie Settings