[KNOWN ISSUE] Alfrike + Blind (e.g. Wu-Kong or Drake) or Dodge (e.g. C-Kadilen, Ninjas etc...): All remaining cubes fail

Thanks for your reply, @KiraSG. Indeed it does not just look like a visual bug to me. As far as i experienced, the enemies neither receive damage after the first missing cube nor mindless attack applies. As discussed earlier, it seems that the mechanic is working in a chain-like manner (cf. Finley, Roostley), which is in conflict to the description of Alfrike’s special.

So finally V30 is live and should have solved this issue. However, there is still something wrong with Alfrike in combination with Wu Kong in dense fog:

And Alfrike in dense fog without Wu Kong:

Neither are five cubes shown, nor do they hit or miss. See a capture below: only three cubes are thrown and two miss (Alfrike in dense fog, no Wu).

@KiraSG could you please check once again?

Marking as “Possibly Solved” as the release notes of V30 say they fixed this.

Not 100% sure that it is only a “visual” thing so will wait for further feedback.

Ref V30 Release notes:

Another evidence that Alfrike is still not working as intended after the V30 update:

Screen capture:

Alfrike was under Joons blindness curse and only two cubes are shown and one of these (surprisingly the first animated one?!) misses. Once again tagging @KiraSG to please check this issue another time. :wink:

Edit: by the way, this happened in alliance war attack


I also noticed today that alfrike has a problem with her cubes if one of them hits a phantom, the cubes stop if one of the targets was a phantom…

Bringing this topic up once again, @KiraSG.
The problem definitely seems not solved and something strange is still going on. I’m not complaining whether I lost a war attack due to this bug, but Alfrike with blindness from Drake throws only four cubes of which the first animated misses:

Could you please check carefully once again and fix it? :pray:

1 Like

Adding to this topic:

Alfrike in scenarios such as dense fog or blinded, it will also fail to throw the cubes, the animation may show more than one cube but there is just one “miss” message, meaning the other cubes didn’t even leave alfrike despite them showing as hitting the targets.

It is frustrating to wait an hour for alfrike to charge mana for the special attack to completely miss, and it’s ok when a special attack misses such as ramming pulverizer, but maybe 2 out of 3 targets arw hit, or 1, or sometimes none, but alfrike’s 1st cube misses and bye bye! All other cubes: Sayonara!

1 Like

Thank you for bring my attention back to this thread - this issue should have been fixed with V 30, please make sure your games are updated. Please let us know if you are experiencing this even after updating the game.


I have version 30.0.2 and this still happens.

Please have it checked.


This happened to me today as well. Alfrike in dense fog, Season 2, Province 20, Level 5 - fires only one cube, and it misses. I tried it multiple times.

  • If it is just visual, then why is there no damage. Multiple times.

  • My game is updated to latest version. Everything else is working fine.

1 Like

This is not possibly solved. Probably should change the topic to Alfrike - Cube Fail, as it is not just with Wu but across multiple instances.

Does anybody know how it is intended to work correctly? Just for understanding, if her special is meant to be one action, like she throws 5 cubes in the air that hits random enemies, so in this case I could understand if there is an all or nothing rule.

If it is meant to be 5 different actions, each cube should be handled as a chance to hit.

The exact wording of the special is:

“Casts 5 Dark Cubes to random enemies”

Even if all the cubes miss … she should still at least CAST all 5.


Iam with you, but in this case it could be possible that it is just something visual and has no effect to the game play.

I’m using version 30.0.2 Build 1296 and against a titan with Wu Kong, twice fired against the titan and both times only one cube was shot. Both times a miss and no other cubes at all. Please remove the possibly solved from the topic… I’d say this is far from solved.

When something is supposed to fire 5 times, but fires only once …and there is no damage done - which is the primary purpose of the game aka fire heroes to kill monsters … and this happens across multiple instances … and multiple people report it … I don’t think calling it a ‘visual error which does not affect the game’ is any kind of a solution.

I put in time, money, mats and feeders into this hero. I expect her to work.


I spent money to pull alfrike, I spent money to upgrade her, I spent weeks upgrading her… alfrike takes around 20 tiles to fully charge, one would think that the enemy would be doomed when she charges, right? Just to get one miserable missed cube. I don’t think it is fair.

Put it this way: It would be like activating Azlar’s fire attack, then only one enemy shows as being burned and on top of that a MISS.

Nope, your wrong.

Just like I said, if the special is supposed to be one action, like the chain reaction specials, then it is the usual way that, if the first cube fails, they are all failing because the whole special fails.

When the special is a chain action - the card says so (see Sir Roostley’s card). When the special is a If-Then action - the card says so (see Finley, Capt Diamonds).

When it says it throws 5 cubes it should throw 5 cubes. Otherwise you could also argue every hero that has a special that says ‘damage to all enemies’ would also stop any damage on the first miss.

So either the special is coded wrong or it is worded wrong, the latter being very attractive to developers as it is an easy fix yet completely out of sync with the general understanding of how the hero works.

Also - referring to the dev response earlier in this thread, they said it was a visual bug. Which means that the hero is supposed to throw 5 cubes, but visually she wasn’t. However, as the very next post points out - if it is just a visual bug, where is the damage?


Seems like there is possibly another issue, we are currently investigating!


Cookie Settings