Join requests not showing

We’ve had several people send us join requests but they’re not showing up for us to accept. We need these folks!

So people trying to join your alliance… They sending a request and its not showing up in your alliance chat?

1 Like

Sometimes that happens if the alliance is not quick enough to accept a potential new member and the player has already joined another new alliance


There is sometimes a delay. Also members won’t see player requests to join :thinking:. You need to be at least an elder.

1 Like

Exactly. After many back and forth texts with support, they weren’t able to help me. The suggestions were irrelevant. I finally had to change the alliance from closed to open, which solved the problem of her request not being seen by anyone, including leaders.

It’s probably still an issue but If the requests still aren’t showing, then I guess we’ll never know, lol.

No delay, just no show.

She’s the daughter of one of our players, so that wasn’t the case.

I have never observed this, but perhaps I just didn’t know someone was trying to join the team. But everyone I’ve recruited on global that tried to join has showed up, even if they have already joined another alliance.

We never had the issue before either. I finally gave up trying to fix it and just opened the alliance for her.

If we see it happen, I will certainly post here

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.