Jackal not working with mana troop

Hi guys can anyone help me

I paired jackal with a lvl 11 mana troop

He still takes 6.5 tiles to charge instead of 6!

Does anyone know wats the issue?

My Jackal is charging in 6 tiles with the appropriate mana troop, so it doesn’t seem to be across-the-board broken in the current version.

Is it possible that your Jackal got hit with the Delay talent, or a mana cut (like Mitsuko) or slow (like Alasie, who slows 3 with a hit)?

1 Like

Mana troop 11 is not enough imo. :slightly_smiling_face:

How high is % mana boost for 11lvl 4* troops?

If they have 7% then:
7% * 6,5 = 0,455
6,5 - 0,455 = 6,045(still 7 tiles)

It must be at least 8% for change 6,5 into 6

Mana boost is 9 at level 11

1 Like

As a philosophical position? Because, by the numbers, it will cut Very Fast from 6.5 tiles to 6.

1 Like

Oops just tried again

Worked fine

Sorry was too hasty to post without checking

1 Like

Glad to hear it’s working! Since there’s no bug, I’m going to go ahead and close this thread.

3 Likes

Cookie Settings