Is Morlovia bugged?

I get disconnected every time I try to start the quest. Is this happening to anyone else? (on android)

Also, when I clicked on the quest, Vivica’s background was missing. I couldn’t take a pic cuz I clicked too fast.

Everything was good for me. Completed without any problems

2 Likes

Weird. It keeps taking me to a connection error message after I click on a Morlovia mission :confused:

Just restart the app. Fixed

2 Likes

Thanks. I tried that a few times but it didn’t work. I’ve sent a support ticket already. Hope it gets solved before the quest ends. I need that tabard badly :confused:

1 Like

There is a new update, hope you have the recent update? If not, perhaps it could help, if you do the update.

2 Likes

Did you update the game? Also, the best way to get rid of such issues, is not restarting the app. Clean the cache, then restart the device.

2 Likes

@Oliz I’ve upgraded to version 25.1.1. I’ll check if there’s another update available.

@Scarecrow I cleaned the cache, restarted the phone and the app but nothing worked. Thanks for the replies though :+1:

3 Likes

I was able to finish after clearing cache a few times, then playing one mission, then clearing cache again… It was tiring :confused:

By the way, Morlovia’s ending is missing the background or it’s just me?

Poor Vivica was in the dark :sweat_smile:

2 Likes

Congrats. Use a cleaning app for your device, uninstall what you do not need, etc. It seems you are short on RAM…

Btw, if you use an app like Line or Discord, you should reinstall it at every several months, to clear a lot of space and also RAM usage.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings