Invite Links Not Working

I have created an invite link and sent it to 4 friends who have never played E&P. I was present when they each opened their emails (they are family and we did it as a group); clicked on the link, the link redirected to the Google Play store (3 are Android and one is IOS), they loaded the game and then completed the tutorial. After completing the tutorial each checked their Invites tab under the game mailbox. Of the 4 accounts two (both on Android) showed that they loaded the game from my invite and two (one Android and one IOS) had the message that they had started playing E&P without a friend invite.

I understand that there are no rewards for the new user until they get to level 5 and for the person inviting until the new user gets to level 10.


  1. How do we link/get credit for a new user if the original process did not work?
  2. Can a new user tell if the invite link worked before having to complete the tutorial. If not there should be a status message added to the tutorial to confirm the invite so the user can uninstall and reinstall (or whatever the fix is) to get the invite working before going through the tutorial. The tutorial was taking about 30-45 minutes for these new users to get all the way through and that is a big waste of time if it will need to be done again to fix this issue.

A post was merged into an existing topic: Why didn’t I get any gift for my account after inviting friends? [SOLVED: Friends must get to Level 10]

Cookie Settings