Invite friends don´t work

i did invite a friend to play, but he is unable to download the game.
after got an email and put the link, just open a picture “download and play”, but nothing happen.
bluetooth invite sais,"link doesn´t exist or it was deleted!!
What can i do?

Buy that friend a new smart phone.

3 Likes

Is it then? As far as I know, it’s a valid answer. It’s an option, but an option you are cheap to acknowledge. You want it to be free, aye yeah, I get you. Of course you do.

Maybe your friend’s phone is a bit obsolete unable to install the game, or that he has a lot of apps or videos or pics stored therein that he doesn’t want to delete any of them resulting for the game not to be installed since the phone lacked the required free memory space. Who am I to know.

Maybe stupidity lies somewhere else than from me. Point to ponder, my friend :upside_down_face:

Goodluck with the downloading, uploading, leftloading and rightloading.

No way!! The phone is empty (factory reset).
I tried to send the invite on my old smartphone, 4 y.o., after factory reset, but same result. :rage:
I put the download button but nothing happen.
After this i tried to download on play store and it was running!! What´s wrong? :roll_eyes:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings