If you are unable to update, PLEASE READ THIS!

We are aware that some players are currently unavailable to update their game. Please follow these instructions on how to resolve the issue:

WARNING! Please do not delete your game. Deleting your game will result in lost progress, if you haven’t connected your game successfully to Game Center or Google Play previously.

iOS

If you cannot update after the game redirects you to the App Store (update is unavailable), please follow these steps and you should be able to update:

Close the game by double tapping the home button and closing the game by swiping it up
Open the App Store and go to the Updates tab
Swipe down to refresh the list. You should now see the Update button next to Empires & Puzzles app. Tap the button to update your game.

Android (“Device not Complatible” error)

If you receive an error message “Device is not compatible” on Google Play Store while trying to update the game, please try the following:

Clear Apps Cache

Go to Settings, then Apps and finally All
Select Play Store, then Clear Cache & Data
Select Empires & Puzzles app, then Clear Cache & Data
Try updating the game again
Unmount SD card

Go to Settings, then Storage and finally Unmount SD Card
Try downloading the game again
Re-Mount SD Card by Navigating to Settings, then Storage, then Re-mount SD Card
Reinstall Google Play Store

Go to Settings, then Apps and finally All
Select Google Play Store, then Uninstall Updates
Try updating the game again

3 Likes

Hello thanks for the info now but it’s late !!! I lost all my progress in game and also the money I spent for the jewels !!! My account still exist as Mark Crow in the alliance Tana dei Lupi , and I need to recover it , please help me , my friend Nelly , the boss of the alliance also wrote you to help me .

2 Likes

Thanks. But your information doesn’t cover my issue.

I’m working on an android emulator. Google play will not let me download the update on the emulator only on an android device (which I don’t have). I need to download the update directly.

Dzięki
Ale to na nic próbowałem już w różny sposób w app store pokazuje się otwórz i kiedy wybierasz to wracasz do swojej gry z napisem aktualizuj i tak w kółko. Z tym że to dotyczy tylko wersji iOS 11 iPad i iPhone ten sam problem. natomiast takie same urządzenie iPhone z iOS 10 bez problemu pobiera aktualizacje i działa.
więc nie wiem co dalej jak na razie jestem zablokowany cały dzień i opisane sposoby nie działają. Chyba też kilka osób pisało w tej sprawie do firmy bo problem dotyczy iOS 11. mam zablokowane urządzenia z napisem aktualizuj i sobie skacze miedzy tym i APP storem a w app stor jest otwórz i odzie do gry z napisem aktualizuj i tak w kółko ??? nie wiem do kogo się zwrócić o przywrócenie mojej gry mam na szczęście zapisane numery ##

Instructions didn’t work for me.
Still get the “Device not Complatible” error at the Play Store.
Hope you guys work on this.
Let me know if there is an other way to make the game work again…

1 Like

Nothing I did fixed the “Device not Complatible” issue. Android Samsung Galaxy 7 on 7.0

1 Like

@d3f3ctiv3 please let me know how.
I use the Samsung Galaxy 7 edge on Android 7.0

1 Like

Lost everything too … been playing this game for 4month …
I won’t start everything again …

2 Likes

None of these steps worked for me either. Using Samsung S7, latest OS. I think you need to roll back the earlier version until you fix this. Most of us won’t wait for long until we move on…

1 Like

I went thru the App Store, and pulled down, resetting the items to be updated; that’s when the new version appeared. Just as instructed in Petri’s post above.

If someone has deleted the game against the advice of SmallGiant, I advise them to contact support directly.

Poszedłem przez App Store i ściągnąłem, resetując przedmioty, które mają być aktualizowane; wtedy pojawiła się nowa wersja. Tak jak zostało to poinstruowane na stanowisku Petri.

Jeśli ktoś usuną grę z poradą SmallGiant, radzę im bezpośrednio skontaktować się z pomocą techniczną.

Realny problem was In the iOS 11 App stor wont Refresht the apps In the iPad . So afterparty hours od closing oppening
The Apps stor gry to appdate
Now is ok
Is good idea to save numer konta twojej gry jeśli kiedyś chcesz ja odzyskać jak stracisz
Juliusz

I tried everything mentioned, but no success. Game isn’t seen on playstore or my S7 and also not compatible. Worst part is…my old S5 can download the new 1.8 release…but then I have to start all over again…not cool spend some cash on the game…im thinking that’s all for nothing…level 23 en now level 2…

This does not work on Samsung 7 series…try another option or roll back old versions so most of us can rejoin our allia and kick titan butts

I can’t even see this in the Play Store now that I deleted. I hope my Google account saved my progress. Wired that only the Samsung 7 is affected. My wife has the 7 edge and i can see it and download it! Help Small Giant, it’s a great game.

I have the Samsung 7 edge and can’t see the game in the play store and can’t download it and can’t update it.

Glitch with new update when attacking Titan. Says fight over and just stops…I had just started the third attack and only got a little over 4,000. Please fix. Thanks

Hey guys,

This worked on a previous update but isn’t working for this one! Please help! I don’t want to be removed from my alliance due to inactivity!

Samsung Galaxy S7. Even when using a PC and trying viewing the Google Store on Chrome it says it’s not compatible.

2017-10-26 15_38_16-Empires & Puzzles_ RPG Quest - Android Apps on Google Play

I did every steps and still I can’t play.

Please help me. Your advice about saving the game comes too late. My account is #32WC and I’ve lost everything. Please fix this as I have worked very hard to get to the point that I am. My email address is iak8084@hotmail.com and I’d appreciate it if you could restore my account. Thank you.

@Opalsunrise You will need to contact Game Support. Please read:


@Petri: Is there a solution for Galaxy SamsungS7? See notes above.

Cookie Settings