I can not Access the Game

Can someone help me? I am unable to access the game. When clicking to start the game, the start screen appears for a few seconds and then it closes and the game does not start. I’m trying to get help through the support by email, but after several questions, they returned that the game is accessible, but I’m still unable to play. Can anyone help me?

Not sure if it’ll help, but I had recently the same problem (game crashed during the loading), check free space on your device. I had to delete some files.

If you are on Android try clearing the app data and cache - it will reload at lot of stuff but won’t lose anything.

NOTE: DO NOT UNINSTALL/REINSTALL - this may lose everything! :scream:

1 Like

I tried several times but it didn’t work.
After receiving an email from SG support saying that there was no problem and that “if you needed anything else just get in touch” (absurd), I decided to take the risk. Losing everything would be a good reason to never play again.

Fortunately it worked, I uninstalled and installed it and the game returned to normal.

As I understand it, the recommendation not to uninstall is just to throw all responsibility to the player. SG support is a joke…

Glad to hear you’re back in the game. :smiley:
Thanks for the update.

I’ve had the lockout issue happen to be a couple of times over the last few years.
Clearing both app data and cache has fixed it for me on each occasion (Android).

Guess I’ve just been “lucky”. :rofl:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.