How to Contact Support (Version 31 Onwards)

Hello, I am Portuguese and I am working in the UK, before coming here already played in Portugal was where I downloaded. I changed Google Play to UK but always asks twice to validate the account: #A2621. Can you help

1 Like

So I have two problems: first i cant add a new topic, there’s no link or option in the forum’s menu. And the second one: today about 9:55 am (+1 cet) i didnt get any loots after killing titan as the only one person in my alliance. I restarted game twice And still get Nothing :(.

1 Like

A post was merged into an existing topic: White mark…?

You need to contact Game Support; only they can untangle your accounts:

https://smallgiant.zendesk.com/hc/en-us/articles/360000542934-How-to-Contact-Support-v1-9-7-onwards-

(Click the article link, read the instructions. If you need to contact Game Support outside of the game, scroll to the bottom of the article and click the blue link, “Submit a Request”.)

2 Likes

This may help:

1 Like
  1. You May not have been on the Forum long enough yet (it requires you to read a certain number of posts, and reply to a number of posts before you can make your own thread.

  2. Are you sure you didn’t get loot? Some people click past the loot screen too fast; they get the loot but don’t know it.

1 Like

Hej,

Thanks for reply. Yes, I did that already. Few min after I wrote to you :slight_smile:
But they don’t understand my problem. You do, obviously. :slight_smile: They wrote: restart game etc. I have send second mail, still waiting for answer.

And second issue - I do not have button: new topic. Is that normal? Do I have to wait for some kind of acceptance?

I will be grateful for reply.

Pozdrawiam
Ewa Szlachetko

1 Like

Usually you need to read a number of articles, and reply to a number of articles before you get the power to make new threads. It shouldn’t take that long. :wink:

O, ok. I didn’t know. Thank you and have a nice evening, I suppose. :slight_smile: It is midnight over here…

2 Likes

A post was split to a new topic: Only getting 3* Heroes

Good time of the day,
Have such an issue with titans and provinces
Hope to get a feedback soon
Thanks

image

1 Like

I continue without solve about my purchase. I had to make a new purchase and the item say the VIP Access will be accumulated, but not yet.

A post was merged into an existing topic: Trading Between Players - Please add your comments & ideas here!

hello …sence last update i have a lot of bugs after finishing a fight whit the titan ,is says a have given 0 gamage…and sometimes i have tow titans on screan

Have you tried turning your game/device off then on again? Sometimes this will reset the game.

If you continue to have this problem, please contact Game Support. See the FAQ article for instructions:

https://smallgiant.zendesk.com/hc/en-us/articles/360000542934-How-to-Contact-Support-v1-9-7-onwards-

@MattiZeus: same advice.

When you purchase the VIP package, you unlock a dragon on your stronghold (clicking it will give you 30 gems per day, for a total of 900 in a month). You also get a second builder. (You’ll notice that you can activate a second build while the first is still going.) Lastly, I believe you get extra Summons, though the 1.10 release notes do not specify that.

2 Likes

You do get an extra daily summon, but it’s possible to miss it if you’re not looking because it makes a double roll with a single button press.

2 Likes

When the first purchase doesn’t work, I made a second purchase VIP Package and I expected both VIP Pacakages where added, but today only have one activated, with a few 20 days remaining, when I 'll have to have a few 50 days

Hello. Today i spend 600 cristal for Ascension pack ice. Need warm cap and fine glover to ascend one my hero…but i receive just 3 item: rugged clothes, adventure’s kit and training manual, no other pack item. Is the twice time who receive just part of pack, and no all item who contain pack. Please help me. I invest more money in this game and think is not fair.

Please report this to Game Support:

https://smallgiant.zendesk.com/hc/en-us/articles/360000542934-How-to-Contact-Support-v1-9-7-onwards-

Cookie Settings