Google Play issue – can’t purchase Dragon Power Offer

Trying to purchase the dragon special and keeps saying server is down.

Multiple players in our alliance is getting the same error as well

I cannot even access the game’s site on Google Play, when I try it also says ‘Server Error’. Almost surely these two things are related.

Edit: Now it works, but actually it says to Update the app but when I try it does not work. Maybe a patch is on its way?

I get the same error when I’m trying to purchase something from the shop

Same whats going on…

I am getting the same error. Unable to make purchases… “server down”

Update… it let me buy 1 but didn’t even give an error when trying to buy more. Just does nothing when button is clicked to buy.

The Google Translator is also Down. I think IT is a problem from google Not e&p.

1 Like

I was able to make the purchase now.

I think the Problem is solved

1 Like

There was a brief issue with the Google Play Store which resulted in some Players being unable to make purchases. We believe the issue is now resolved. If you are still experiencing any issues, please send through a support request and we can investigate the issue further. I hope you’re all having a great weekend! :slight_smile:

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings