Game won't update

My tablet has version 1.11.6 and no update is available on the play store. My phone is on version 1.11.7.

Are your phone and tablet different (android and iOS)?

I know some Android players have not yet seen the update in Googleplay. (SG has been know to stagger the release of game updates over IOS/Android so as not to overwhelm the system).

Still no update available on PlayStore! I have tried refreshing etc, no luck.

(Sorry, should clarify. I have Android )

Hi, the latest update is 1.11.6 on Android and 1.11.7 on iOS. Apologies for the missing communication on this. It’s the same update despite the version numbers - we released one more update for iOS to fix a few platform specific bugs.

4 Likes

Thanks Petri! :blush:

1 Like

Thanks for the update. It might pay to use the ingame messaging system to clarify the point for android users - there seem to be a lot of confused people looking out for android updates. Until I read your post I was one of them, and not every player reads the forums.

1 Like

Cookie Settings