Game stuck at "Connecting..."


#1

I logged on to game a couple hours ago with no issues. Now, when I log on it loads, but is stuck at “connecting…”.

I took a screenshot of it with my acct#. Please advise how to fix this.

Thanks.


#2

Do not post your account number. (You can edit it out of your screenshot.)

Are you still having this issue?


#3

need to fix the bug in wars it is unfair match making and get kicked at the end of some wars and lose are points it’s not right for us and all other teams!!!


#4

I already had the problem. I restart my phone, and the game connects


#5

Rook, I can only log into the game via wifi. For some reason when using data it will absolutely not connect. I don’t understand how it can work one day and not the next.

I’ll even go one further which seems really odd. If I am playing the game at home using wifi, keep the game play open and then switch to data (once I’m out of wifi area) the game will continue to function as normal. Soon as the game disconnects (while using data) I am unable to connect until I am using wifi again.

Not that it’s a bad thing, I can focus better at work, lol. Though, it is frustrating and have no clue what caused it to change over night. Especially since Empires and Puzzles is the only thing which is affected. I can visit websites, watch videos via Netflix, Amazon or Youtube, play other games, etc. See, strange.


#6

Yes I agree it’s strange.

As for war issues, if you are getting disconnected, and have tried the troubleshooting on the FAQ for connectivity, please send in a ticket for Support to SG:




Internet connection bugs
#7

I been having the same problem for 6 days my game won’t connect my data is good. I have done every trouble shooting and still won’t connect


#8

Still trouble? After trying about 10 different thing, I turned my phone off for a few hours (over night) and it seemed to suddenly work. I dont know why it stopped or why it started again. Was crazy is all I know. Good luck.


#9

You expect something smart from support to say and they would come with “we suggest to report from in game to report a bug”
Hellooooo which part of I can not connect you guys do not understand! I can not connect at all to the game, sais no internet connection from the same connection Im writing the same thing. Everything else is working except the game! Watching metflix from the same connection and you really want me convinced that my connection is not ok, really?


#10

I have the same issue. Game gets stuck trying to connect. When it connects, sometimes Google Game connector doesn’t. Other times, I get an error saying there is a problem with my connection that it cannot find “asset server”. Please fix asap.


#12

I have the same issue. Game gets stuck trying to connect.


#13

I have to turn my wifi off and play using data. I’ve had this issue for two months or more. I can stream videos on wifi but not play this game, it’s strange.


#14

I’m having the same issue after the update


#15

I am having the same issue since the update. The game no longer connects with WiFi. It does connect when I turn off WiFi on my phone and turn on data. All other apps are functioning normally so I know it is not a problem with my router.


#16

I have an issue using WiFi. It will let me connect and when I go to titan it will always get stuck. I have lost my attack flag and get no points. I should not have to keep losing flags that I have to wait4 hrs for next one.


#17

This most likely will require SG’s direct help:


#18

Hello.I have the same problem.when i’m on wifi the game works O.K.
It doesn’t want to connect…restarted phone, shut down for some…still the same…
Anybody got feedback on this jet??

Edit:doesn’t want to connect to mobile data.


#19

Am having this issue now… Updated app… Cleared cache… Restarted phone… Any other suggestions?


#20

I have the some problem,i whas playing and suddenly i got out from game and now I can’t loggin,it’s stuck on the “loading “screen


#21

same here stuck at connecting. Connection failed