Frozen screen when loading the game

Hello! Ever since the last update, sometimes when i open the game, the screen is just black. No SG logo, no loading, it’s simply frozen. Usually after i close and open it again, it loads properly after the second attempt, but recently it’s starting to require two-three attempts in order to load. I have a galaxy s7, so the phone is not the issue, considering everything worked properly before the update. It is not a big issue, but it can get annoying since it starts to happen more and more frequently. Thank you!

1 Like

This also happened to me, a couple of times this morning. Game gets stuck on the black screen and the small giant games logo will not appear

I’d try treating it like a crash. Here’s the steps SG recommends for that:

It’s also possible that clearing the game cache will help, although I’d make sure I was on WiFi before doing that, since they’ll be re-downloading a lot of stuff afterward.

1 Like

After the launch of this new vs.20, when I start the game, a black screen appears and I cannot enter . At least other member of my alliance has the same problem.

What happens? Is it a bug? Everything was working perfectly before the new version.

Thanks for your help

@helenika2017 I moved your post to a report that sounded similar. Unfortunately, the OP of this thread didn’t update with whether they were able to resolve it.

Can you start with the troubleshooting article
that @Garanwyn linked to above, and let us know if any of it helps?

Thanks! :slight_smile:

I had this happen to me since v20.0: using Galaxy s7. Today I got sick of it and used google…

Apparently this model does/can run into wifi connection problems - along with frozen/black screen my phone would also “drop” wifi connection randomly.

I’ve put a link to an article specifically for s7 users - apologies if not allowed mods.

The step that has worked for me is to remove power saving; since doing this the game loads normally the first time with no screen blackout.

1 Like

Yes I have recently noticed that when I switch to data, the game loads with no issues. Still interesting since this crashes never happened in the previous versions

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.