Free gems in store Zynga

Nabend
bei mir ist das nirgends zu finden hab es auch gehört das es juwelen gibt

2 Likes

Try removing the notification permissions and deleting the bookmark link. Maybe even clearing the cache. Wait a bit and go into the webstore again.

4 Likes

Being discussed here…

Can @PlayForFun or @Dudeious.Maximus work their merge magic ?

5 Likes

Ughh, I looked there but clearly missed. Thank you!

Yes, merge please and thank you.

3 Likes

Thanks for the heads up! Much appreciated.

2 Likes

Please feel free to tag me for merges as well in the future.

2 Likes

Enjoy your 20x 3 star dupes, 8 4* dupes and a couple of 3* noobs :yum:

1 Like

Copper! Have you just been named a Mod? If so congrats and thanks for taking up the task!

2 Likes

Thanks for the welcome Chadmo! I’m actually a returning mod. I haven’t been active for two or three years, but I was made a mod back when the forum started in 2017. :smile:

7 Likes

Well then a big welcome back to you! I recall the name, I must still have a little bit of memory in this feeble old brain of mine.

Cheers!

2 Likes

Enjoy your pessimism and gray clouds, Negative Ned :wink: no thanks for raining on my parade

2 Likes

I remember you, glad to see you again :slight_smile:

2 Likes

Why did you return after all that time away?

1 Like

I DON’T HAVE SUCH WINDOW!!
Also @Ei-Dunn probably didn’t have it

1 Like

You need to use the native browser for some reason.

I have Android, and normally use FireFox, but had to switch my default browser (temporarily) to Chrome for this to appear.

For IoS use Safari.

Good luck. :four_leaf_clover:

1 Like

Im just bitter because that’s what they gift me with when I do 10x pulls

2 Likes

Maybe your next one will be better :wink:

My worst one only had a Kashhrek and 9 dupe 3* to show for it

1 Like

I’m on Android, using Chrome, and still didn’t have it

1 Like

Is Chrome set as your default browser?

I had FireFox as my default and the offer did not appear even when visiting the site using Chrome. It only worked after setting Chrome to be the default.
( I’ve now changed it back :rofl: )

1 Like

I don’t have any other web browser. I use and have on that device only Chrome