Failed purchase

Hey guys, i‘m trying to buy the new offer but it isn’t working! tried it several times on different devices, still not working.image does anyone have the same problem?

I have this issue too. Have you heard anything about when it might be fixed?

Worked for me after restarting the app. Sometimes I even had to restart after a purch to receive the items.

Don’t panic and don’t do other purchs or the same multiple times. If one purch doesn’t finish correctly, try to resrart the app and don’t do other purchs. Just restart the app and wait until the purch finishes completely.

It also helps to wait for all the popups e.g. offers or loot chests, click the offer afterwards from its icon and not directly from the popup.

If nothing solves the problem, open an ingame support ticket to get help from SGG.

Thanks Olmor. Is restarting the game just closing it and opening it (which I’ve done) or do I need to delete the app and reinstall it?

No, just close and reopen it.

I restarted the game several times, also deleted it, no results. I even tried it on three different devices…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings