“Exhausted” Mystic Vision Error Message

I’ve had the dreaded red X, for over 24 hours, so far, none of the “fixes” have worked. Only does it on the acct on my Moto phone. I miss my gem! Lol Hope you fix the issue soon, had only started with last update for me.

I’m running a few accounts on my computer using Bluestacks emulator. It not against T.O.S. but it’s not supported either.

However, Mystic vision is often broken for me there. I find if I return to my phone it will work. Restarting the emulator program sometimes works.

I believe the problem with mystic vision lies in tying it to our google play accounts for advertising tracking. Try restarting google play services as well. Restarting both the game and google play services should be the band-aid to get mystic vision working again until SGG changes the way they interface mystic vision together.

@TijaraTaj did you contact support? If none of the suggested fixes here worked then it’s something more serious.

Reboots are still usually working for me. Occasionally it will not for the old Galaxy. When 3 reboots don’t get it working, clearing the E&P cache almost always does.

У меня такое часто. Когда интернет медленный, тогда видео долго загружается в мой телефон, чтобы был просмотр. Когда видео загрузится полностью, тогда такая надпись не появляется больше, и справа внизу исчезает красный крест, и я могу посмотреть видео и получить бонус.

I’ve been getting the exhausted messages consistently the past two weeks. The only thing I know it coincides with is connecting Facebook to it.

I occasionally get it, too. Closing and re-opening the app usually works for me

I just started experiencing this issue, and no amount of app restarts, phone restarts, resetting my Google advertising ID or various combinations of these helped at all. It was only by clearing my E&P storage cache that I found success. I do not have FB either.

This morning (2 hours ago) I’v meet this error and nothing help me. Now start the game again and everything is OK.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

For over 2 days i have not had access to Mystic Vision videos however, the 3 other players in my household have no issues. I recently migrated to a Ipad Pro 4th gen could it be that ?

Force close the app or restarting your phone tends to work for people.

Have issues accessing MV for the past few days. Always tell me that there is no ads available blah blah… but in the mean time I have no problems viewing ads on all my other games.

In the first two days when I had this problem, the ad will eventually pop out 1-2 hours after displaying the “not available” msg. But it has been completely down over the past day or so.

Tried all methods recommended by ppl above but none of these worked.
1 - restart game or iPhone
2 - keep tapping the msg
3 - switch back and forth between arena, map and base

Curious if anyone has other solutions to recommend before I submit a ticket on Monday? Thanks a lot

Same problem here, looks like it started since I updated to 36.

A post was merged into an existing topic: [KNOWN ISSUE] Mystic Vision doesn’t work (23 Mar)

2 posts were merged into an existing topic: [KNOWN ISSUE] Mystic Vision doesn’t work (23 Mar)

Cookie Settings