Error Communicating with the asset server

I usually play from wifi connection and the game works no problem. Sometimes I play from US T-Mobile Data connection. For the past month or two, I almost always get this message when on the T-Mobile connection:
“There was an error communicating with the asset server. This can be caused by using a proxy”.

Phone OS: Android 8.0.0

Last time this happened was 7/16/2018 at about 9:15pm MDT (GMT-6)
Here is screenshot:

Did you ever get an answer? I’ve been having the same issue all day today

nope, I contacted support last week and they gave me canned, unhelpful responses.

It looks like the issues you have experienced are related to issues with connectivity.
Empires & Puzzles is an online multiplayer game, it’s essential that you are connected to a reliable network and your device signal is strong.

Please try the following troubleshooting tips:

  1. Restart your router (Turn off power then unplug. Plug back in, turn on the power and try reconnecting)
  2. Move your router. Depending on your router’s range, objects like thick walls can interfere with the signal.
  3. If you are using a wireless connection, check your router configuration and make sure the port 8443 is open.
  4. Contact your service provider for further information.
  5. Try another internet connection. We recommend playing over wireless (wifi) connection.

I pushed back because all the above is useless to my situation, and they replied:

Like most mobile, multi-player games, Empires & Puzzles requires a stable internet connection. We recommend you use a reliable wifi network and regularly empty your device memory (closing apps, restarting your device, and/or removing any unused apps) otherwise it may cause you to lose a battle.

Once your device gets disconnected from your internet connection, any task performed in-game is not registered on our servers before the disconnection. At this time we are not able to compensate or undo the actions that have already been performed due to “game crashes”. We understand this can be frustrating, but network issues are beyond our control.

I started getting these yesterday on two different Wi-if routers, only on Android (never happens on my iOS device) and only when raiding.

Finally got another answer:

The fact that 3G or 4G cellular connection is sometimes not strong enough to download new assets for the game. A weak or unstable network will result in many crashes and the inability to run the game as seen. Please kindly keep in mind that once the asset bundles are successfully downloaded, you should most likely be able to play normally with your cellular network.
In other words, whenever you see that “There was an error communicating with the asset server” pop up, please connect to your nearest wifi network and download the asset bundle before proceed to play normally with your own cellular network. As I also mentioned in one of the last messages, we recommend playing over wireless (wifi) connection.

Some commentary:

  • It seems like they have it backwards. Downloading assets is a problem we have solved over spotty connections… you just index your downloads so you can resume when the bandwidth becomes available. I would think they care more about the pvp having a reliable signal. But what do I know.
  • My experience is the minute I step off a wifi connection, I can do one or two actions, not even a full battle, before I get kicked with “unable to connect to asset server”.
  • I’m starting to think this is a stale cache problem: E&P app reads stale cache on my device, so then it tries to re-download all the “assets”, but maybe keeps the old versions. I’m thinking it also caches DNS records or random links to their CDN (content distribution network), and when I switch to a mobile network, it uses the stale values, pointing to cloud servers that don’t exist anymore.

After the new update the war is kicking out of the game

@beyto045 That’s a pain, but the good news is it’s an error message I’ve seen on the forum before, and might be easy to solve.

There are some tips from support in these threads for this specific error message, I suggest you read through and follow all of the steps posted in each as a first attempt to fix this:

(@Kerridoc @Rook @Coppersky Possible Merge of Topic)

If you try everthing listed in both of those threads, see if there’s anything different suggested here:

If none of that works, then I suggest you contact support. They recommend contacting from within the game, but presumably you can’t get there…

So here’s the direct link to submitting a ticket:

If you do manage to get into the game but are still having issues, here are the instructions for contacting support from within the game: How to Contact Support (v1.9.7 onwards)


Merged. :slight_smile:

1 Like

I was very angry in the morning. 3300 team power and I got this message and voila… 0 points. Are you kidding me?? And it’s not the first time. Pretty annoying.

@BloodRayne Please see this post above in this thread for suggestions for solving it, and how to contact Support if you continue having issues:

I have been having this issue several times each ti e i play. I have had tne issje during raids, normal provence mining, and just working on heros/etc. Each time i loose flags, rewards, etc. Now tne valentine event is crashing before i can start. I cant play as this “server” issue ruins battles or rewards.

I use android and wifi access. No proxies like your error msg suggezts. Fix it. At least aknowledge the issue

And your links for sugessted fixes do not link to the posts but instead to the users profile. That is a wortless link and only creates more problems and frustration.

I have been playing this game for over a year-and-a-half several times a day and have never seen this error message before. I have never used a Wi-Fi connection. Only my Sprint phone. Updated the app 3 days ago and have been getting this error message ever since when trying to go into raids

I’m. Getting this error but only on trials of survival. I’ve tried mobile data and a WiFi connection and I still get the same error. I’m signed in to my Google play account.

Any ides?

Did you already try everything listed in the “solution” post above?

Guys i had the same issue with connecting to e&p using mobile data and I “fixed” my issue by using a vpn app. I use Turbo VPN and once I connect to the vpn, I can connect to the game shortly thereafter. Hope this helps.

Yeah I did mate, Weirdly on the second restart of my phone it worked ok, so not sure what the issue was!

Now it seems my titan chest isn’t filling after killing a titan. At first i thought I’d missjudged it but I’ve just been part of killing a titan again and it still shows 0/5

Glad to hear it worked the second time around!

Assuming you didn’t leave and rejoin the alliance at any point before the titan died, and your chest isn’t in cooldown, that sounds like there might be some issue with your account.

I’d suggest contacting Support to ask about that one:

Cookie Settings