Could not collect recruits from Advanced House

Has anyone seen this problem? I tried to collect recruits from the advanced house, and the game showed the visual animation but the counter didn’t change . This happened at around 6:55-6:57 PST.

Was your recruit storage full alread?

Does “stuff to collect” symbol remain above your advanced house?

Edit, just checked my own and it worked.

I’ve lost over 100 recruits before. Decided the support tickets useleness would have made me angrier.

EDIT: 144

No, the “collect” symbol disappeared. My recruits weren’t full before, it was at 1 and remained at 1 after collection.

I finished a Jotunheim stage and that filled recruits successfully, so it wasn’t a visual bug or a counter error, but something specifically related to the Advanced House.

100 recruits? Yikes.

1 Like

I should be more honest. They did give me 67 recruits back a couple of minutes later…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Cookie Settings