Costumes are stuck, can't unequip heroes

when I open a hero card from my roster I can equip or unequip that hero with a costume using the arrow buttons or the “equip” button. However when I then close the card, go back to the roster the hero has the costume on regardless.

The hero in question is not on any team, neither AW defense nor tournament, nor any of the 5 default teams.

This happens on my alt. account as well.

restarted, logged out, back in, still stuck

That sounds like a real issue - I had an update notification on my phone when I logged in today, and ran it. Have you updated recently? Is there an update available on your device?

Just to make sure you’re using the ‘equip’ option correctly, can you verify this is what you’re doing?

  1. Open the card
  2. Use the arrow (Since you indicated the costume was equipped, it should be the left arrow)
  3. Tap the ‘equip’ button. It should turn yellow and say ‘equipped’
  4. Exit the card

Your hero should now show the Regular, non-costumed version of the hero. Is this happening?

4 Likes

If the OP is running update version 25.1.1
Clicking the left arrow will revert the card to the original hero with equip button option.
Clicking equip button will bring a pop up menu


Then clicking the colored equip button once again will ensure the original hero is equipped.

The OP should confirm actions taken.

1 Like

@Oliz That may be an Android feature. I am running v25.1.1 on an iPhone and don’t receive the pop up. Interesting that is should be different… Regardless, something that may impact the OP. Thanks for the addition!

1 Like

Hi LadySuzanne, thanks you are right, that works. I got confused, I thought you “equip” the hero with their costume, “unequip” them to get them back to normal. But I need to “equip” them with normal!

I’m not getting the pop-up menu either. Running v25.1.1 on Android. Maybe that’s the bug.

3 Likes

@HerrKa Glad that worked! It confused me at first as well :smile: Not sure why some are showing the pop up and others aren’t. It may be the specific type of device Oliz is using. :woman_shrugging:

@rook @zephyr1 @DaveCozy (and any other mod) it looks like this one is solved and can be closed.

2 Likes

I ran IOS not Android…anyway good the OP had it resolved.

Solved, as you say. :slight_smile: I will leave this open a little while longer if anyone else finds additional issues.

Cookie Settings