Can't upgrade stronghold


#1

My stronghold is at level 13. In order to upgrade it, I need 753k iron. I have all of my iron storages and mine’s at max level. I can only store 736k iron. It is impossible for me to upgrade. Even when I try to spend gems to get the required iron to upgrade, i cant, because my storage won’t hold enough, and it gives me a message to upgrade my stronghold, which is what I have been trying to do already. Why is this happening?


#2

Your barracks is on an Iron Storage.

Move it to a forge or something and the problem is solved.


#4

I have three barracks. Moving them doesn’t change how much iron I can store. I just tried.


#5

You can only have 1xBarrack (The place where you can upgrade troops)

If you click on it, and click convert (the two arrows) it should show an Iron Storage underneath.

Convert another building into a Barrack and that frees up your Iron Stoeage so you can accumulate enough iron to continue your Stronghold

edit
These buildings are often confused in the terminology.
Barrack = Upgrade troops. You can only ever have 1 Barrack.
Training Camp = Trains heros. You can have a maximum of 4 Training Camps with Stronghold lvl20


#6

Yesterday i was upgrade my stronghold to lvl 7 and after elapsed time hwen i was checked when i can start upgrade to lvl 8 there was same message Wait time : 11h 45m. What to do?


#7

Are you saying that tou started a vuild but the timer hasn’t decreased while the sh was under construction?


#8

Its finished SH is now on lvl 7 but problem is that i cant upgrade it to lvl 8 encounter is stuck on 11h 45m, When i klick on SH to upgrade there is message Wait time: 11h 45m. That was time how i need to wait if i wish to lvl up SH .


#9

Weird, there should only be a wait if you’re building something. If nothing else is being built, contact support.
https://smallgiant.zendesk.com/hc/en-us/requests/new


#10

thank you ill try on your link