Can't update to V29

I am using Android…

Same issue on Android. No v29 available. I raised a ticket with SG support. So far they gave only the standard answer ‘clearc cache, reboot uninstall app’. Well, this time none of this works.
What is next ?

I raised a ticket 2 hours ago and they didn’t respond back. I tried manually downloading the most updated version of Google Play - didn’t work either.

May be this link may help: https://forums.oneplus.com/threads/google-play-store-is-not-showing-the-application-updates.613868/

I ended up downloading a V29 apk online and installed that on my phone. Ended up solving the issue for me

Thank you everyone for reporting this and submitting Support requests. We are aware this is an issue and are investigating here.

5 Likes

Happy to hear that :blush: only downside of this situation is that I bought Path of Valor pass a day before. Good luck on that fix!

Could you share a link?

1 Like

Same problem here. Any link would be usefull

This version worked for me. Simply uninstall EP then install with the v29 apk.

1 Like

I see you already found a working link. Here’s the one I used:

https://apkpure.com/empires-puzzles-epic-match-3/com.smallgiantgames.empires

I uninstalled the Game and reinstalled It. Worked for me

Hello, I am running the game under Android with a note 9 that had a software update version N960FXXU5DTCA/N960FOXM5DTCB/N960FXXU5DTC9. When I launch the game it announces the new released version 29 and takes me to play store. However there is no button to install update . Only Open and uninstall are available. Press open button returns me to the game that keeps revert me back to play store.
I have the game on another device and it has updated fine and works well.
Any help please or fix the bugg on Samsung Note 9
Many thanks

I also have a note 9 & don’t have the update yet. The game isn’t asking me to update yet, but I’ve cleared cache & data for play store & E&P, uninstalled play store updates & reinstalled them, restarted the phone, uninstalled & reinstalled E&P, manually checked for updates to installed apps in the play store…idk what else to do besides just wait, but i’m afraid i’ll end up in the situation you are in where the game requires the new version but I don’t have it available to download. I’ll let you know if I figure anything out…good luck!

And have you fully turned off your device and restarted it or perhaps tried to update play app

I’ve tried everything listed and still have no update. Im the only one in my alliance without the update. Im on a s7 in the usa.

Your not on your own
https://forum.smallgiantgames.com/t/cant-update-to-v29/176707/32

Just got the update finally. Showed up randomly in the play store after all this time. Good luck to everyone else…hopefully it is available to all soon! Also, I’m new to the forums (lurked for a long time though) & didn’t know how to edit my original post in this thread, so i’m just replying here. Is there a more appropriate way to edit a previous reply or how is that usually handled?
Thanks!

We have now rolled out the update for both iOS and Android, you should be able to update now or at least within the next few hours! Thank you for your patience. :slight_smile:

1 Like

Thanks, it helped for me! :blush:

Cookie Settings