Can't play any season 3 stages

When I click on them, I get booted out of the game and get a connection error. My next stage is 6-7, but I went back to province 1 and tried to play a stage on hard and had the same thing happen. Is this a known thing going on right now? I have Android, and up to date with updates…

[…moderator edit to remove account ID…]

I just logged in now & am playing S3-10-5 without any issues.

Also on android here.

What is your Version number & build number?

Sorry about the screenshot.

My alliance mates aren’t having any issues either. It is annoying. I was trying to level up and collect some Valhalla coins in the process.

When players are booted out of the game or game crashes.

  1. Make sure that game version is newest
  2. Make sure that device OS is newest
  3. Delete your game from devices (assuming that you have connected to Game Center or Google Play account)
  4. Reboot your phone and re-install the game.

This should in general fix this problem

It fixed itself I guess. Finally after several attempts, it worked. Thanks for the input.

@Guvnor - you can close this now.

1 Like

Cookie Settings