Cant get past the update page

My tablet popped up the update available box. I clicked on update, it take me to play store and empires pops up with open lit up. I press open it runs me right back to update available box. Round and round. my account is #[removed by mod] version 19.3.0 build 914.
I have been using this same device for about 9 months. It is a tab 4

Moderator’s Note: please do not post game account numbers on the Forum for security purposes.

Have you tried refreshing the list of app updates? Usually if you do after getting that message, the new update will show up after a manual refresh of the update list.

The Support site also has this article that might help:

tried no luck…

That’s frustrating. Did you try everything in the Support article too?

do i have to all at once or each

It looks like it says to try one section at a time, and then try updating again after each section

i have no idea how to find some of these like undoing card and all

I’m not sure, unfortunately. I have an iPhone, personally.

Maybe just try the ones you can do at least?

i have been…

1 Like

thank you for the help :slight_smile:

1 Like

You’re welcome! Is it working finally?

not yet i am still messing with it

1 Like

i give up for now will just play on the phone

Sorry it’s not working. :confused:

I guess playing on the phone until the update shows up on your tablet is a decent option in the meantime at least.

I had to go to a 3rd party site and load it

So did you get the update installed that way finally?

Suffering with same problem here, dzenpad 8 user. I guess issue is on google playstore side, can be fixed by installing update from third party site. I’m too lazy to check, try’ll it tomorrow.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.