Can't connect to server today - PROBLEM STILL PERSISTING!

New to E&P . First post on forum, hi all.
Have the same problem :cry:
Motorola
Android v7 and v8
Latest game version

Having this problem too. Given this thread it seems pretty widespread…an word from devs?

Also can’t connect. First time this has happened. Have tried all suggestions- not a problem on my end so must be something with the game itself.

Same problem here.
Samsung
Updated today
Using will fi

1 Like

Same here. Canada. Can’t connect.

1 Like

Same here. Stuck on connecting error…

1 Like

I can only get on using data. I had problems before and after updating today.
I’m using iOS 12.4.1
Game version 24.1.0
Can’t use WiFi.

2 Likes

On iOS, most recent update, can play on LTE but not on WiFi

3 Likes

I cant connecteither. Worked fine at lunch and now doesn’t work. Build24.1.0 version 1145. Using my tablet on wifi with android is.

2 Likes

Connection error based on your screenshot is only caused due to your interent connection not providing the game with enough speed to upload it whether it be Wifi, Data or Eithernet.

Trying Doing a speed test.

Possible cause for slow internet is;

  1. bill not paid on time
  2. data usage has maxed out. This also can happen with unlimited plans as every plan has a cap under fair usage laws.
  3. ISP provider doing work in the area
  4. Peek periods
  5. Your devices memory has maxed out for this game thus not having enough rom to open it.

Just to name a few more common ones.

But this is not a server issue. If it where a sever error your message would read something like this,
Can’t connect to server” or “the server you are trying to reach is not working at the moment

But in any case it would have the word server in the message. If it doesn’t it’s NOT a server issue. That you can bank on.

I don’t necessarily agree with this. I can play any other game on my tablet and also game on my pc. It is only this game having an issue.

3 Likes

Oh, and I’m posting from the same tablet over the same wifi that my game uses.

Having same issue!

Moderator edit to remove image with account information

2 Likes

Every games resource requirements are very different. You might be opening games which only requires minimum data to open.

I know it’s always easier and simplier to blame the actual game but there are many other factors involved 99% of the time.

But most of the time these message like the one displayed above is caused from internet speed issues which is why it’s asking to find another Network.

LOL YES I have no doubts that you are.

A website which is what this forum is doesn’t require much data to open. Plus the fact that this forum is more than likely on a different server to the game anyway would be no indication of what the game is doing.

Trust me, I know and understand your problem but my salutation or reasons for it happening haven’t changed because they are the underlying causes of your problem and there is nothing SG can do to solve your problem as they know this as well, other than wait and your ISP will have the issue solved eventually unless the problem is a none payment one in which case only you can solve.

I had problems connecting via Wifi on my phone and my computer using bluestacks. When I could connect on my phone using data, I researched and found this is the solution. I would randomly not be able to connect.

Answer was to change my DNS servers in the Router.

I have had no problems since then.

I can get in now.I used phone data that worked.Then Rebooted modem.And can now login using wifi…

If you continue to experience random inability to connect during the next couple weeks, try changing your DNS servers in the router/modem.

This problem with the E&P servers. High Speed Internet, and working perfectly. Two android devices with E&P and not able to connect to E&P game servers, only connectivity issues experiences is with this game. Internet never gives problems, but I anyways unplugged for couple of minutes and plugged it back gave it chance then tried E&P again. No difference so I forgot WiFi and re-entered the WiFi login information. No difference so I re-booted the tablets and again… no difference.

E&P is with latest, and the only thing that made a difference was clearing the game cache. All fixed for both tablets now.

Great to hear guys.

It always makes it a bit easier when you spot and think about it.
Oriontron’s suggestion of restating your routers is also a very good 1st option as it can slow your services down.

Happy Gaming Guys

Cookie Settings