Cannot update can't get into the game anymore

#1

I spent many hundreds of dollars on this game with gems that I have not even used now I can’t even get in on my phone every time this game tries to update it just becomes a nightmare for me. Is anybody else having trouble on this update issue I hate to think I’m the only one and I sent it support ticket but no response. Anybody else having problems?

#2

For me the update worked fine (android).

Basic advice in such situations: restart your phone and update directly from Playstore or Appstore.
Hope it works soon!

2 Likes
#3

I was locked out on my tablet for a few days. I tried going directly through Google Play but it wasn’t showing an update option. My issue resolved after my third complete shutdown and restart.

#4

Probably there is a problem with you google if it was an android phone. Try logout and login again to your goggle account / googleplay.
If you can’t connect to internet, enable the BACKGROUND DATA in your phone setting.
Else, run virus scan. Soft reset or completely turn off then turn on the phone again might help in some way.

#5

@Thundermask please follow profloki’s suggestion, STAT!!

1 Like